Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604442 - sane-backends-1.0.21-2.fc12 breaks xsane
sane-backends-1.0.21-2.fc12 breaks xsane
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-15 17:52 EDT by Dieter Stolte
Modified: 2010-06-17 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 11:43:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dieter Stolte 2010-06-15 17:52:14 EDT
Description of problem:
after upgrading sane-backends to version 1.0.21-2.fc12 scanning in gimp with xsane-gimp 0.997-3.fc12 stopped working. After downgrading sane-backends to 1.0.20-10.fc12 scanner worked again.


Version-Release number of selected component (if applicable):
sane-backends-1.0.21-2.fc12 (64bit)

How reproducible:
always

Steps to Reproduce:
1. open gimp
2. goto file->create(?, second menu item)->"xsane: select device" or "xsane: <device>"
3. in one case the scanner is found but preview is not working because it hangs. in the other case the scanner cannot be initialized. 

Actual results:
xsane not working anymore

Expected results:
xsane should work

Additional info:
- xsane standalone also doesnt work.
- hardware is epson V500
- driver used: iscan-2.24.0-4.ltdl7.x86_64.rpm and iscan-plugin-gt-x770-2.1.1-2.c2.x86_64.rpm
Comment 1 Nils Philippsen 2010-06-16 11:43:19 EDT
I see that you use the proprietary driver necessary for your scanner model. Unfortunately I can't say what goes wrong with that and the new sane-backends library version, please contact Avasys/Epson about that. You might have a (slight) chance to find that out for yourself if you attempt to build their drivers from sources (well, sources plus binary object code).

Sorry that I can't help you more with that :-(.
Comment 2 Dieter Stolte 2010-06-16 19:07:56 EDT
So you verified that the combination of xsane and the new sane-backends package is working with scanners supported by sane itself?
Comment 3 Nils Philippsen 2010-06-17 09:28:33 EDT
I have checked it out with a flatbed scanner I own, both using xsane stand-alone and as a GIMP plugin worked with both previewing and scanning. I suspect that the proprietary driver uses sane-internal API which has changed between .20 and .21, but that's just guesswork (it contains its own copy of the sanei/ directory which defines sane-internal interfaces).
Comment 4 Dieter Stolte 2010-06-17 09:42:36 EDT
Ok, thanks. Will have a look at the epson code.

Note You need to log in before you can comment on or make changes to this bug.