Bug 604555 - neon has extra characters after %{?dist}
Summary: neon has extra characters after %{?dist}
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: neon (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact: Michal Nowak
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 08:34 UTC by Daniel Mach
Modified: 2013-03-08 02:10 UTC (History)
5 users (show)

Fixed In Version: neon-0.29.3-1.2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:11:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Mach 2010-06-16 08:34:07 UTC
There are extra characters after %{?dist} in package release.

actual NVR:
neon-0.29.3-1.el6.1

correct NVR:
neon-0.29.3-1.1.el6

Comment 1 RHEL Product and Program Management 2010-06-16 08:53:47 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Nalin Dahyabhai 2010-07-06 17:12:59 UTC
(In reply to comment #0)
> There are extra characters after %{?dist} in package release.
> 
> actual NVR:
> neon-0.29.3-1.el6.1
> 
> correct NVR:
> neon-0.29.3-1.1.el6    

That looks right to me, if the goal is to sort correctly against a previously-built neon-0.29.3-1.el6.

Comment 4 Joe Orton 2010-07-07 13:28:40 UTC
There seems to be an oddity in rpm vercmp, that it treats "1.el6.1" and "1.el6_1" as equal.

$ rpmdev-vercmp 0 1 1.el6.1 0 1 1.el6_1
These are equal

which seems kind of insane, but maybe that's expected.

This seems to drive Daniel's concern that the usual habit of changing %dist and adding a ".1" after the %dist will not work.

I don't see that this is a big deal. If we need a Z-stream errata for neon we will bump the release to 1%{?dist}.2.  For a Y-stream errata we can bump it to 1.1%?{dist} or whatever.  Everything will work as expected.  I'll push this out since it doesn't seem blocker-worthy.

Comment 8 releng-rhel@redhat.com 2010-11-10 21:11:52 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.