Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604628 - TypeError: object of type 'bool' has no len()
TypeError: object of type 'bool' has no len()
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
anaconda_trace_hash:7f33ce557e095fb54...
:
: 604937 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 07:20 EDT by Ales Kozumplik
Modified: 2014-09-30 19:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-13.21.52-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (122.59 KB, text/plain)
2010-06-16 07:20 EDT, Ales Kozumplik
no flags Details
Attached traceback automatically from anaconda. (117.57 KB, text/plain)
2010-06-16 22:54 EDT, A S Alam
no flags Details

  None (edit)
Description Ales Kozumplik 2010-06-16 07:20:43 EDT
The following was filed automatically by anaconda:
anaconda 13.21.51 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/simpleconfig.py", line 26, in uppercase_ASCII_string
    for i in range(0,len(str)):
  File "/usr/lib/anaconda/simpleconfig.py", line 84, in get
    key = uppercase_ASCII_string(key)
  File "/usr/lib/anaconda/network.py", line 452, in getOnbootControlledIfaces
    device.get('NM_CONTROLLED' == "yes")):
  File "/usr/lib/anaconda/gui.py", line 992, in enableNetwork
    waited_devs = self.anaconda.id.network.getOnbootControlledIfaces()
  File "/usr/lib/anaconda/iw/network_gui.py", line 67, in _setupNetwork
    self.intf.enableNetwork(just_setup=True)
TypeError: object of type 'bool' has no len()
Comment 1 Ales Kozumplik 2010-06-16 07:20:47 EDT
Created attachment 424405 [details]
Attached traceback automatically from anaconda.
Comment 2 Ales Kozumplik 2010-06-16 07:22:59 EDT
went the network screen, clicked 'Configure Network', clicked on all the tabs in there, changed nothing, clicked okay. sad panda.
Comment 4 RHEL Product and Program Management 2010-06-16 07:33:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Radek Vykydal 2010-06-16 07:37:31 EDT
Patch fixing a typo sent to anaconda-devel-list.
Comment 6 Radek Vykydal 2010-06-16 08:49:57 EDT
This should be fixed in anaconda-13.21.52-1. Moving to modified.
Comment 7 A S Alam 2010-06-16 22:54:46 EDT
Created attachment 424649 [details]
Attached traceback automatically from anaconda.
Comment 8 Radek Vykydal 2010-06-17 03:56:56 EDT
*** Bug 604937 has been marked as a duplicate of this bug. ***
Comment 10 Alexander Todorov 2010-07-05 05:00:50 EDT
Fixed with anaconda-13.21.56-1.el6 / 0701.3 tree.
Comment 11 releng-rhel@redhat.com 2010-11-10 14:48:20 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.