Bug 604699 - ipa-client-install --uninstall fails if installed with --no-sssd option
ipa-client-install --uninstall fails if installed with --no-sssd option
Status: CLOSED DUPLICATE of bug 604704
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On: 604704
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 10:20 EDT by Jenny Galipeau
Modified: 2011-10-20 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 13:23:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2010-06-16 10:20:48 EDT
Description of problem:
If the ipa-client-install is executed with --no-sssd option, ipa-client--uninstall fails:

[root@jennyv2 ~]# ipa-client-install --uninstall
Removing Kerberos service principals from /etc/krb5.keytab
Disabling client Kerberos and Ldap configurations
Failed to remove krb5/ldap configuration. Command '/usr/sbin/authconfig --disableldap --disablekrb5 --disablesssd --disablesssdauth --disablemkhomedir --update' returned non-zero exit status 1
[root@jennyv2 ~]# ipa-client-install --no-sssd
IPA client is already configured on this system.


[root@jennyv2 ~]# /usr/sbin/authconfig --disableldap --disablekrb5 --disablesssd --disablesssdauth --disablemkhomedir --update
Traceback (most recent call last):
  File "/usr/sbin/authconfig", line 894, in <module>
    sys.exit(module.run())
  File "/usr/sbin/authconfig", line 478, in run
    self.readAuthInfo()
  File "/usr/sbin/authconfig", line 329, in readAuthInfo
    self.info = authinfo.read(self.printError)
  File "/usr/share/authconfig/authinfo.py", line 922, in read
    info.read()
  File "/usr/share/authconfig/authinfo.py", line 2174, in read
    self.readSSSD()
  File "/usr/share/authconfig/authinfo.py", line 1531, in readSSSD
    domain = self.sssdConfig.get_domain(domname)
  File "/usr/lib/python2.6/site-packages/SSSDConfig.py", line 1456, in get_domain
    if (opt['name'], opt['value']) not in providers]
  File "/usr/lib/python2.6/site-packages/SSSDConfig.py", line 888, in set_option
    (self.name, option))
SSSDConfig.NoOptionError: Section [ldap] has no option [mid_id]


Therefore the uninstall needs a --no-sssd option too - or even better - should automatically detect that sssd is not being used.

Version-Release number of selected component (if applicable):
ipa-client-2.0-7.el6.i686

How reproducible:
always

Steps to Reproduce:
1. ipa-client-install --no-sssd
2. ipa-client--uninstall
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-16 10:32:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Dmitri Pal 2010-06-16 11:19:20 EDT
IMO the right way to fix this bug is to fix the bug https://bugzilla.redhat.com/show_bug.cgi?id=604704. Adding it as dependency.
I am not sure we need to duplicate the checks in the ipa-client to make sure that SSSD was not configured.
Comment 4 Stephen Gallagher 2010-06-16 13:23:00 EDT

*** This bug has been marked as a duplicate of bug 604704 ***

Note You need to log in before you can comment on or make changes to this bug.