Bug 604717 - RFE: make it possible to read console.log without downloading
Summary: RFE: make it possible to read console.log without downloading
Status: CLOSED DUPLICATE of bug 600098
Alias: None
Product: Beaker
Classification: Community
Component: web UI   
(Show other bugs)
Version: 0.5
Hardware: All Linux
low
medium vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 15:06 UTC by Alexander Todorov
Modified: 2014-12-08 01:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 15:24:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Todorov 2010-06-16 15:06:23 UTC
Description of problem:

The console.log file sometimes may contain non printable characters such as color codes for example. The result is that the file is treated as binary and the user can't read it directly in the browser but instead is offered to download the file. This is also problematic because by default (at least for me) GNOME tries to open the file with gedit which fails because it can't determine text encoding. 

This RFE is to make it possible that the console.log is viable in the browser directly. It's 99% text so forcing text/plain sounds safe.

Version-Release number of selected component (if applicable):
0.5.42 

How reproducible:
Always

Steps to Reproduce:
1. Try downloading a console.log from a Beaker job. For example from here https://beaker.engineering.redhat.com/jobs/3405
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bill Peck 2010-06-16 15:24:26 UTC

*** This bug has been marked as a duplicate of bug 600098 ***


Note You need to log in before you can comment on or make changes to this bug.