Bug 60472 - Can't compile Mysql 3.23.47
Summary: Can't compile Mysql 3.23.47
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 01:54 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-07 10:45:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-02-28 01:54:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
After running make i give the following error :
c++ -DUNDEF_THREADS_HACK -I./../include                                 -
I../include -I./.. -
I..                             -I..    -O3 -DDBUG_OFF   -fno-implicit-
templates -fno-excepti
ons -fno-rtti -c mysql.cc
mysql.cc: In function `int main (int, char **)':
mysql.cc:347: Internal error: Erreur de segmentation.
Please submit a full bug report.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.tar -xvzf mysql-3.23.47.tar.gz
2../configure --prefix=/usr/local/mysql --enable-assembler --with-innodb
3.make
	

Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-02-28 15:40:43 UTC
Version of the compiler? FWIW, I compiled 47 without problems when it was current.

Comment 2 Need Real Name 2002-02-28 15:46:54 UTC
Following packages are installed :
gcc-2.96-98
gcc-g77-2.96-98
gcc-c++-2.96-98
glibc-2.2.4-19.3
glibc-devel-2.2.4-19.3
glibc-common-2.2.4-19.3

Hop it can help you.
Same situation are perfectly running on an other server with BP6-Celeron.

Comment 3 Trond Eivind Glomsrxd 2002-02-28 16:09:23 UTC
Where did you get your mysql srpms? Did you set any specific opt flags (I use
"-O2 -march=i386 -mcpu=i686
")?

Comment 4 Need Real Name 2002-03-05 13:50:11 UTC
I didn't specify any opt flags. The sources where donwload from mysql.com as 
tarballs.

Comment 5 Trond Eivind Glomsrxd 2002-03-05 19:45:16 UTC
Reclassifying as a GCC problem. FWIW, the above did not happen with our builds
of the same version.

Comment 6 Jakub Jelinek 2002-03-07 10:44:55 UTC
Is it reproduceable?
If yes, please attach preprocessed source and mention which gcc options
you used (e.g. pass -save-temps in addition to other g++ options).

Comment 7 Trond Eivind Glomsrxd 2002-08-21 18:39:56 UTC
Closing due to lack of feedback.


Note You need to log in before you can comment on or make changes to this bug.