Bug 604769 - SELinux is preventing /bin/rm "getattr" access on /var/lib/mysql/mysql.sock.
SELinux is preventing /bin/rm "getattr" access on /var/lib/mysql/mysql.s...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f2f0eea6ec3...
:
: 604770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 13:27 EDT by Steven Stern
Modified: 2010-06-16 14:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 14:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Stern 2010-06-16 13:27:19 EDT
Summary:

SELinux is preventing /bin/rm "getattr" access on /var/lib/mysql/mysql.sock.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by rm. It is not expected that this access is
required by rm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:mysqld_safe_t:s0
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                /var/lib/mysql/mysql.sock [ sock_file ]
Source                        rm
Source Path                   /bin/rm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.4-6.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-124.fc13.i686.PAE #1 SMP Fri Jun 11
                              09:42:24 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Wed 16 Jun 2010 12:25:27 PM CDT
Last Seen                     Wed 16 Jun 2010 12:25:27 PM CDT
Local ID                      ffc0739c-539c-4202-85e2-fa07172a1dc2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276709127.381:35): avc:  denied  { getattr } for  pid=2562 comm="rm" path="/var/lib/mysql/mysql.sock" dev=dm-0 ino=397695 scontext=unconfined_u:system_r:mysqld_safe_t:s0 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1276709127.381:35): arch=40000003 syscall=300 success=yes exit=0 a0=ffffff9c a1=8ef1b10 a2=8ef1ab0 a3=100 items=0 ppid=2477 pid=2562 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="rm" exe="/bin/rm" subj=unconfined_u:system_r:mysqld_safe_t:s0 key=(null)



Hash String generated from  catchall,rm,mysqld_safe_t,var_lib_t,sock_file,getattr
audit2allow suggests:

#============= mysqld_safe_t ==============
allow mysqld_safe_t var_lib_t:sock_file getattr;
Comment 1 Daniel Walsh 2010-06-16 14:31:37 EDT
You have a mislabled directory.

restorecon -R -v /var/lib

Should fix.  If it becomes mislabeled again, please reopen.
Comment 2 Daniel Walsh 2010-06-16 14:32:01 EDT
*** Bug 604770 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.