Bug 604793 - [PATCH] Correct Font Information for MS Symbol encoding
[PATCH] Correct Font Information for MS Symbol encoding
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fontmatrix (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 14:19 EDT by Paul Flo Williams
Modified: 2010-07-07 13:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: fontmatrix-0.6.99-6.r1073.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:52:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to correct the display of name records (same as upstream) (978 bytes, text/plain)
2010-06-16 14:19 EDT, Paul Flo Williams
no flags Details
Free symbol font (4.88 KB, application/x-font-ttf)
2010-06-17 02:26 EDT, Paul Flo Williams
no flags Details
Fontmatrix showing symbol font before patch (123.77 KB, image/png)
2010-06-17 02:27 EDT, Paul Flo Williams
no flags Details
Fontmatrix showing symbol font after patch (117.70 KB, image/png)
2010-06-17 02:31 EDT, Paul Flo Williams
no flags Details

  None (edit)
Description Paul Flo Williams 2010-06-16 14:19:55 EDT
Created attachment 424544 [details]
Patch to correct the display of name records (same as upstream)

Description of problem:

For fonts that have the name table encoding as MS Symbol (platform 3, encoding 0), Fontmatrix currently displays the string "Here, imagine some nice symbols!" for all name records, because the specifications don't seem to say how the name recs are encoded.

I created a patch to fix this six months ago and submitted it upstream, as bug 14897 <http://gna.org/bugs/?14897>, but upstream development seems rather sluggish, so I'd like to recommend this patch for Fedora's package in advance of acceptance upstream.

The patch changes Fontmatrix to interpret the name record encoding as UTF-16BE. I produced the patch against Subversion revision 1088, but I have just tested it against r1073 included in Fedora and it works.

Version-Release number of selected component (if applicable):

fontmatrix-0.6.99-4.r1073.fc13

How reproducible:

Always

Steps to Reproduce:
1. Import a dingbat font into Fontmatrix.
2. Go to the Font Information tab.
  
Actual results:

For fonts that have "MS Symbol" listed alongside "Charmaps List", all other name records will say "Here, imagine some nice symbols!" instead of showing real information.

Expected results:

Dingbat fonts have proper information in the name records, but Fontmatrix doesn't know how to display it.

Additional info:
Comment 1 Parag Nemade 2010-06-17 00:47:53 EDT
Can you give me images of what is existing and what will be new information in fontmatrix window?

I applied patch and run fontmatrix but I don't know where to see changes. Also, I am unable to see "Here, imagine some nice symbols!"

Dingbat font I checked is /usr/share/fonts/default/Type1/d050000l.pfb
Comment 2 Parag Nemade 2010-06-17 01:14:47 EDT
Also, I am going to scratch build new fontmatrix with your patch on koji. Can you check this build is what you want and working?
http://koji.fedoraproject.org/koji/taskinfo?taskID=2254775
Comment 3 Paul Flo Williams 2010-06-17 02:26:14 EDT
Created attachment 424681 [details]
Free symbol font

This font is marked internally as freeware, and displays the problem shown in the screenshots (next two attachments).
Comment 4 Paul Flo Williams 2010-06-17 02:27:58 EDT
Created attachment 424682 [details]
Fontmatrix showing symbol font before patch

Note that the Charmaps List says "MS Symbol". There can be multiple charmaps, but the font must contain this one for the bug to show.
Comment 5 Paul Flo Williams 2010-06-17 02:31:32 EDT
Created attachment 424684 [details]
Fontmatrix showing symbol font after patch

Fontmatrix can now correctly show the contents of the name records.

Note that Fontmatrix loads name records into its database when fonts are imported, so to see the improvement, you need to wipe the database (rm -r ~/.Fontmatrix) before re-importing the font.

I have 1039 fonts that are affected by this bug, and this patch corrects the display for all of them.
Comment 6 Paul Flo Williams 2010-06-17 02:38:46 EDT
(In reply to comment #2)
> Also, I am going to scratch build new fontmatrix with your patch on koji. Can
> you check this build is what you want and working?
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2254775    

I downloaded and installed the x86_64 RPM linked from there, and it solves the problem, thank you.
Comment 7 Parag Nemade 2010-06-17 05:35:47 EDT
Do you know any font in Fedora that is having this problem?
Comment 8 Paul Flo Williams 2010-06-17 06:23:21 EDT
(In reply to comment #7)
> Do you know any font in Fedora that is having this problem?    

I don't offhand, but I haven't installed every Fedora font package. The example font you picked in comment 1 didn't show the problem because it is a Type 1 font. Only TrueType fonts have name tables.

I could certainly package the font I attached to this bug ;-)
Comment 9 Parag Nemade 2010-06-18 00:14:53 EDT
I tried to reproduce this problem with existing Fedora packaged fonts. But unable to reproduce it. So, I think if I need to commit this patch, we should have this bug reproducible.
Comment 10 Parag Nemade 2010-06-18 00:26:23 EDT
Ok. I had a look at font file now. Saw its not Unicode font. I think its better to ask upstream to make it unicode.

I use many commands but no satisfactory output has come from this font like fontaine, gnome-font-viewer, fontmatrix, otfinfo.


I will close this as NOTABUG as this needs actually fix in font file not in fontmatrix.

There are many True type fonts in Fedora whose information is correctly shown in fontmatrix.
Comment 11 Parag Nemade 2010-06-18 03:09:51 EDT
Ok. After having discussion with reporter on IRC, I see we should have this patch committed.
Comment 12 Fedora Update System 2010-06-18 03:13:15 EDT
fontmatrix-0.6.99-6.r1073.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fontmatrix-0.6.99-6.r1073.fc13
Comment 13 Fedora Update System 2010-06-21 08:53:02 EDT
fontmatrix-0.6.99-6.r1073.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fontmatrix'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fontmatrix-0.6.99-6.r1073.fc13
Comment 14 Fedora Update System 2010-07-07 13:52:02 EDT
fontmatrix-0.6.99-6.r1073.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.