Bug 604810 - remove crashkernel=auto and use default syntax and move some decisions to user space
Summary: remove crashkernel=auto and use default syntax and move some decisions to use...
Status: CLOSED DUPLICATE of bug 605786
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cong Wang
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 18:55 UTC by Vivek Goyal
Modified: 2013-09-30 02:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-11 03:14:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vivek Goyal 2010-06-16 18:55:01 UTC
Description of problem:

crashkernel=auto parameters seems to be doing too much. It also seems to be taking some policy decisions which are better taken in user space. One of such
decisions is that do not reserve any kdump memory on systems having less than
4G of ram. It might be better to move this policy decision in user space.

One possible place is some service in kexec-tools package and use /sys tunable "crash_kexec_size" to reduce the amount of memory reserved. May be by default we can reserve 128MB of memory and then shrink it by user space policy.
Version-Release number of selected component (if applicable):

This should be targeted for RHEL6.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2010-06-16 19:32:58 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 RHEL Product and Program Management 2010-07-15 14:36:44 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 4 Cong Wang 2011-02-11 03:14:58 UTC

*** This bug has been marked as a duplicate of bug 605786 ***


Note You need to log in before you can comment on or make changes to this bug.