Bug 604811 - libvirt: node device APIs don't list wireless interfaces
libvirt: node device APIs don't list wireless interfaces
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
All Linux
low Severity medium
: rc
: ---
Assigned To: Dave Allan
Virtualization Bugs
Depends On: 596928
  Show dependency treegraph
Reported: 2010-06-16 14:57 EDT by Dave Allan
Modified: 2016-04-26 11:24 EDT (History)
10 users (show)

See Also:
Fixed In Version: libvirt-0_8_1-10_el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 596928
Last Closed: 2010-11-11 09:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Allan 2010-06-16 14:57:59 EDT
+++ This bug was initially created as a clone of Bug #596928 +++

The udev node device backend doesn't list wireless interfaces. This causes an issue with virt-manager users if trying to create interfaces via the 'interface' APIs: if they remove their wireless sysconfig file, the card needs to be listed by the node device APIs so we can offer to readd the config.

Fixed upstream here:

Comment 1 RHEL Product and Program Management 2010-06-16 15:15:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
Comment 3 Dave Allan 2010-06-23 21:26:37 EDT
libvirt-0_8_1-10_el6 has been built in RHEL-6-candidate with the fix.

Comment 5 Nan Zhang 2010-07-09 09:53:02 EDT
Verified with libvirt-0.8.1-13.el6.x86_64. Moving to VERIFIED.

# lspci
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

# virsh nodedev-list --cap pci

# virsh nodedev-dumpxml pci_0000_03_00_0
  <capability type='pci'>
    <product id='0x4237'>PRO/Wireless 5100 AGN [Shiloh] Network Connection</product>
    <vendor id='0x8086'>Intel Corporation</vendor>
Comment 6 releng-rhel@redhat.com 2010-11-11 09:49:53 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.