Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604812 - condor tools can't act upon condor_kbdd
condor tools can't act upon condor_kbdd
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Robert Rati
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 14:58 EDT by Robert Rati
Modified: 2010-10-20 07:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2010-06-16 14:58:29 EDT
Description of problem:
The condor tools are unable to act upon the kbdd daemon:

condor_restart -subsystem kbdd
ERROR "Unknown daemon type (7) in Daemon::init" at line 1007 in file daemon.cpp


Version-Release number of selected component (if applicable):
7.4.3-0.18

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2010-06-16 15:24:30 EDT
The issue is that, internally, the kbdd has its own daemon type, but it is not recognized by the Daemon::locate method.  Added the kbdd to the list of daemon types locate will handle, and use NO_AD as the ad type since it doesn't register with the collector.

Fixed in:
condor-7.4.3-0.20
Comment 2 Robert Rati 2010-06-16 15:28:24 EDT
Make that:
condor-7.4.3-0.21
Comment 3 Luigi Toscano 2010-09-27 16:23:52 EDT
condor_reconfig/condor_restart now accept -subsystem kbdd and properly operate on it.

Verified on RHEL 4.8/5.5, i386/x86_64.
condor-7.4.4-0.15
condor-kbdd-7.4.4-0.15

Note You need to log in before you can comment on or make changes to this bug.