Bug 604817 - Can't live migrate Windows VM on RHEL 5.5 x86_64
Summary: Can't live migrate Windows VM on RHEL 5.5 x86_64
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-16 19:14 UTC by Simon Gao
Modified: 2010-06-17 16:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 16:22:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Gao 2010-06-16 19:14:30 UTC
Description of problem:

Two identifical servers running RHEL 5.5 x86_64. Multiple vlans configured. The Windows VM is configured on vlan 40 with correspondinger bridge interface. The VM works fine with the vlan.

Version-Release number of selected component (if applicable):

Linux server2 2.6.18-186.el5xen #1 SMP Wed Jan 27 18:19:45 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:


Steps to Reproduce:
1. Configure multiple vlans and bridge interfaces on two 5.5 servers
2. Install Windows VM on one server with vlan 40 (non-default vlan) on 
   bridge xenbr40
3. Run live migration from command line:
   xm migrate -l <vm> <second server>
  
Actual results:

# xm migrate -l windowVM server2
Error: /usr/lib64/xen/bin/xc_save 24 24 0 0 5 failed
Usage: xm migrate <Domain> <Host>

Migrate a domain to another machine.

Options:

-h, --help           Print this help.
-l, --live           Use live migration.
-p=portnum, --port=portnum
                     Use specified port for migration.
-r=MBIT, --resource=MBIT
                     Set level of resource usage for migration.


Expected results:

The windows VM should be migrated to server2 without any issue

Additional info:

Comment 1 Miroslav Rezanina 2010-06-17 09:25:42 UTC
Can you please provide xend.logs from both machines and guest configuration?

Comment 2 Simon Gao 2010-06-17 15:58:27 UTC
Please close this ticket.

The problem was the destination server does not have same nfs share. Once the nfs issue is fixed, then live migration worked.

Comment 3 Bill Burns 2010-06-17 16:22:48 UTC
Ok, thanks.


Note You need to log in before you can comment on or make changes to this bug.