Bug 60484 - binutils: ld "S-records" XFAILS
Summary: binutils: ld "S-records" XFAILS
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact:
URL:
Whiteboard:
Keywords:
: 60485 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 13:45 UTC by Christopher Holmes
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-28 18:23:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Holmes 2002-02-28 13:45:41 UTC
Description of Problem:

	binutils: ld "S-records" XFAILS

Version-Release number of selected component (if applicable):

	binutils-2.11.90.0.8-12.src.rpm

How Reproducible:

	always

Steps to Reproduce:

1. rpm -i binutils-2.11.90.0.8-12.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpm -ba binutils.spec
4. cd /usr/src/redhat/BUILD/binutils-2.11.90.0.8
5. make -k check
6. review ./ld/ld.log

Actual Results:

gcc -L/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld
-B/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/tmpdir/gas/
-I/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-srec -O2 -mieee  -c
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-srec/sr1.c -o
tmpdir/sr1.o
gcc -L/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld
-B/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/tmpdir/gas/
-I/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-srec -O2 -mieee  -c
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/testsuite/ld-srec/sr2.c -o
tmpdir/sr2.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/ld-new  -o tmpdir/sr1  -Ttext
0x1000 tmpdir/sr1.o tmpdir/sr2.o
/usr/src/redhat/BUILD/binutils-2.11.90.0.8/ld/ld-new  -o tmpdir/sr2.sr  -Ttext
0x1000 --oformat srec tmpdir/sr1.o tmpdir/sr2.o
tmpdir/sr1.o: In function `main':
tmpdir/sr1.o(.text+0x8): relocation truncated to fit: ELF_LITERAL data
tmpdir/sr1.o(.text+0x38): relocation truncated to fit: ELF_LITERAL e1
tmpdir/sr1.o(.text+0x3c): relocation truncated to fit: ELF_LITERAL e2
tmpdir/sr1.o(.text+0x40): relocation truncated to fit: ELF_LITERAL i
tmpdir/sr1.o(.text+0x44): relocation truncated to fit: ELF_LITERAL j
tmpdir/sr1.o(.text+0x50): relocation truncated to fit: ELF_LITERAL sbss
tmpdir/sr1.o(.text+0x58): relocation truncated to fit: ELF_LITERAL sdata
tmpdir/sr2.o: In function `fn1':
tmpdir/sr2.o(.text+0x8): relocation truncated to fit: ELF_LITERAL e1
tmpdir/sr2.o: In function `fn2':
tmpdir/sr2.o(.text+0x38): relocation truncated to fit: ELF_LITERAL e2
XFAIL: S-records

Expected Results:

PASS: S-records

Additional Information:

	expected results achieved on intel RedHat7.2

Comment 1 Alexandre Petit-Bianco 2002-03-27 21:17:59 UTC
ld should be passed an extra argument (-Tdata <value>) and then the S record
output file will be generated.

We're taking note that binutils' testing infrastructure needs to be fixed
with regard to this case.







Comment 2 Alexandre Petit-Bianco 2002-04-01 19:17:42 UTC
*** Bug 60485 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.