Bug 604850 - [abrt] crash in openoffice.org-core-1:3.2.0-12.24.fc13: getTypeName: nsplugin. (Calibre related ?)
[abrt] crash in openoffice.org-core-1:3.2.0-12.24.fc13: getTypeName: nsplugin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:f1000b9c22ad89066c8e7173de4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 16:34 EDT by Michal Nowak
Modified: 2013-03-07 21:10 EST (History)
2 users (show)

See Also:
Fixed In Version: openoffice.org-3.2.0-12.25.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 14:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (60.46 KB, text/plain)
2010-06-16 16:34 EDT, Michal Nowak
no flags Details
Another similar OO.o crash (64.38 KB, text/plain)
2010-06-18 08:22 EDT, Michal Nowak
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 107490 None None None Never

  None (edit)
Description Michal Nowak 2010-06-16 16:34:11 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/basis-link/program/nsplugin 31 32 -env:INIFILENAME=vnd.sun.star.pathname:/usr/lib/openoffice.org3/program/redirectrc /usr/lib/openoffice.org3/program
component: openoffice.org
crash_function: getTypeName
executable: /usr/lib/openoffice.org/basis3.2/program/nsplugin
global_uuid: f1000b9c22ad89066c8e7173de40013ef3e2c0d0
kernel: 2.6.33.5-112.fc13.i686
package: openoffice.org-core-1:3.2.0-12.24.fc13
rating: 4
reason: Process /usr/lib/openoffice.org/basis3.2/program/nsplugin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Michal Nowak 2010-06-16 16:34:13 EDT
Created attachment 424585 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-06-17 03:43:43 EDT
Looks like the firefox plugin that has crashed. Are you able to reproduce this, is there a quick and easy way to get it to happen again ?
Comment 3 Michal Nowak 2010-06-17 04:07:02 EDT
I guess it's reproducible. What I do: Have this http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/epub/Developer_Guide/Red_Hat_Enterprise_Linux-6-Developer_Guide-en-US.epub ePub file and wanted it to be converted to MOBI, so my Kindle can read it. So opened Calibre (0.7.1), added that file to Library and then converted from ePub to MOBI. That made the crash (saw it today once again when converting Developers Guide.

I dunno if/why/how Calibre uses OO.o in this conversion. (Well Firefox was opened that time.)
Comment 4 Caolan McNamara 2010-06-17 04:47:13 EDT
Hmm, I sort of feel Calibre is a co-incidental red-herring here. If you repeat the conversion does the crash indicator appear ?
Comment 5 Michal Nowak 2010-06-18 08:22:28 EDT
Created attachment 425097 [details]
Another similar OO.o crash

Hmm, nope... Tried twice and it did not appeared. It happened to me yesterday again, with this traceback (however abrt said it's "another crash" -- I can file it as separate bug if you want me to).
Comment 6 Caolan McNamara 2010-06-18 08:39:10 EDT
No, its the same problem, the issue is what is triggering the problem. So I assume that you have the openoffice.org firefox plugin enabled ?, i.e. is tools->options->internet->browser plugin togged on or off ?

It's clear that its another related to the lifecycle issue around shutting down multiple threads. I do have a patch I put into devel which definitely fixes part of this story, but it may not be complete. Ideally I could get a (at least semi-) reproducible scenario for this one to see if its fixed by that theoretical fix.
Comment 7 Caolan McNamara 2010-06-18 11:09:47 EDT
I'll try that anyway, should help clarify this anyway even if not a complete fix. Stay tuned for a test-build on Mon or something.
Comment 8 Fedora Update System 2010-06-21 04:49:48 EDT
openoffice.org-3.2.0-12.25.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.25.fc13
Comment 9 Fedora Update System 2010-06-21 17:37:55 EDT
openoffice.org-3.2.0-12.25.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.25.fc13
Comment 10 Michal Nowak 2010-06-28 06:06:40 EDT
(In reply to comment #6)
> No, its the same problem, the issue is what is triggering the problem. So I
> assume that you have the openoffice.org firefox plugin enabled ?, i.e. is
> tools->options->internet->browser plugin togged on or off ?

I have this enabled.

(In reply to comment #7)
> I'll try that anyway, should help clarify this anyway even if not a complete
> fix. Stay tuned for a test-build on Mon or something.    

I believe I updated to this new version -- no crash so far.
Comment 11 Fedora Update System 2010-07-01 14:58:21 EDT
openoffice.org-3.2.0-12.25.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.