Bug 604878 - [RHEL6] NULL pointer dereference in ixgbe on ixgbe_vlan_filter_enable()
[RHEL6] NULL pointer dereference in ixgbe on ixgbe_vlan_filter_enable()
Status: CLOSED DUPLICATE of bug 601066
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-16 18:02 EDT by Aristeu Rozanski
Modified: 2010-06-16 21:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 21:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aristeu Rozanski 2010-06-16 18:02:19 EDT
Description of problem:

While rebooting after the installation:
---
waiting for mdraid sets to become clean...
sending termination signals...done
sending kill signals...done
rebooting system
BUG: unable to handle kernel NULL pointer dereference at 00000026
IP: [<f8195333>] ixgbe_vlan_filter_enable+0xb3/0xe0 [ixgbe]
*pdpt = 000000003453d001 *pde = 0000000000000000 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/firmware/edd/int13_dev80/mbr_signature
Modules linked in: ext4(U) jbd2(U) fcoe(U) libfcoe(U) libfc(U) scsi_transport_fc(U) scsi_tgt(U) xts(U) lrw(U) gf128mul(U) sha256_generic(U) cbc(U) dm_crypt(U) dm_round_robin(U) dm_multipath(U) dm_snapshot(U) dm_mirror(U) dm_region_hash(U) dm_log(U) dm_zero(U) dm_mod(U) linear(U) raid10(U) raid456(U) async_raid6_recov(U) async_pq(U) raid6_pq(U) async_xor(U) xor(U) async_memcpy(U) async_tx(U) raid1(U) raid0(U) ext2(U) mbcache(U) nfs(U) lockd(U) fscache(U) nfs_acl(U) auth_rpcgss(U) sunrpc(U) sg(U) sd_mod(U) crc_t10dif(U) ata_generic(U) pata_acpi(U) radeon(U) ttm(U) drm_kms_helper(U) mptsas(U) ixgbe(U) mptscsih(U) drm(U) mptbase(U) dca(U) i2c_algo_bit(U) i2c_core(U) mdio(U) bnx2(U) ata_piix(U) scsi_transport_sas(U) ipv6(U) iscsi_ibft(U) pcspkr(U) edd(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) squashfs(U) cramfs(U) [last unloaded: scsi_wait_scan]

Pid: 1, comm: init Not tainted (2.6.32-33.el6.i686 #1) IBM eServer BladeCenter HS21 -[7995G1U]-
EIP: 0060:[<f8195333>] EFLAGS: 00010246 CPU: 0
EIP is at ixgbe_vlan_filter_enable+0xb3/0xe0 [ixgbe]
EAX: c1ba83c0 EBX: c1ba83c0 ECX: 00000000 EDX: 00000000
ESI: f9080000 EDI: 00000000 EBP: f7173800 ESP: f706fe14
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Process init (pid: 1, ti=f706e000 task=f7053a90 task.ti=f706e000)
Stack:
 c1ba83c0 c1ba8000 f8198363 00000286 c1ba9400 c1ba83c0 00000000 c1ba8000
<0> f7173800 f819b98b 0000001e f706fe5b f7173800 f7173860 28121969 f706fe80
<0> f819b9ff 28121969 f7173800 c05f6ab6 f7170060 c069ebb0 00000003 28121969
Call Trace:
 [<f8198363>] ? ixgbe_set_rx_mode+0xd3/0x1e0 [ixgbe]
 [<f819b98b>] ? __ixgbe_shutdown+0x12b/0x190 [ixgbe]
 [<f819b9ff>] ? ixgbe_shutdown+0xf/0x40 [ixgbe]
 [<c05f6ab6>] ? pci_device_shutdown+0x16/0x30
 [<c069ebb0>] ? device_shutdown+0x40/0x150
 [<c046a010>] ? kernel_restart_prepare+0x20/0x30
 [<c046a05b>] ? kernel_restart+0xb/0x50
 [<c045ab5d>] ? capable+0xd/0x40
 [<c046a233>] ? sys_reboot+0x183/0x210
 [<c0473900>] ? lock_hrtimer_base+0x20/0x50
 [<c04745f2>] ? hrtimer_try_to_cancel+0x32/0xb0
 [<c0474681>] ? hrtimer_cancel+0x11/0x20
 [<c081807d>] ? do_nanosleep+0x8d/0xc0
 [<c0474747>] ? hrtimer_nanosleep+0xb7/0x150
 [<c066d9d9>] ? tty_write+0x1c9/0x230
 [<c0473780>] ? hrtimer_wakeup+0x0/0x20
 [<c04745b0>] ? hrtimer_start_range_ns+0x20/0x30
 [<c0474838>] ? sys_nanosleep+0x58/0x60
 [<c04098fb>] ? sysenter_do_call+0x12/0x28
Code: 28 10 00 00 8d 14 16 81 cb 00 00 00 40 89 1a 83 c1 01 39 88 20 0e 00 00 0f 8e 78 ff ff ff 8b 94 88 20 0c 00 00 8b b0 40 10 00 00 <0f> b7 52 26 83 fa 3f 7e ac 89 d3 c1 e3 06 81 c3 28 c0 00 00 eb 
EIP: [<f8195333>] ixgbe_vlan_filter_enable+0xb3/0xe0 [ixgbe] SS:ESP 0068:f706fe14
CR2: 0000000000000026
---[ end trace 37a75f9e30e08e2e ]---
Kernel panic - not syncing: Fatal exception
Pid: 1, comm: init Tainted: G      D    2.6.32-33.el6.i686 #1
Call Trace:
 [<c08163cf>] ? panic+0x42/0xed
 [<c0819b0c>] ? oops_end+0xbc/0xd0
 [<c04303f2>] ? no_context+0xc2/0x190
 [<c043067b>] ? bad_area+0x3b/0x50
 [<c081ade0>] ? do_page_fault+0x0/0x480
 [<c081b253>] ? do_page_fault+0x473/0x480
 [<c075a750>] ? pci_read+0x30/0x40
 [<c05f04c3>] ? pci_bus_read_config_byte+0x63/0x80
 [<c081ade0>] ? do_page_fault+0x0/0x480
 [<c0818eeb>] ? error_code+0x73/0x78
 [<f8195333>] ? ixgbe_vlan_filter_enable+0xb3/0xe0 [ixgbe]
 [<f8198363>] ? ixgbe_set_rx_mode+0xd3/0x1e0 [ixgbe]
 [<f819b98b>] ? __ixgbe_shutdown+0x12b/0x190 [ixgbe]
 [<f819b9ff>] ? ixgbe_shutdown+0xf/0x40 [ixgbe]
 [<c05f6ab6>] ? pci_device_shutdown+0x16/0x30
 [<c069ebb0>] ? device_shutdown+0x40/0x150
 [<c046a010>] ? kernel_restart_prepare+0x20/0x30
 [<c046a05b>] ? kernel_restart+0xb/0x50
 [<c045ab5d>] ? capable+0xd/0x40
 [<c046a233>] ? sys_reboot+0x183/0x210
 [<c0473900>] ? lock_hrtimer_base+0x20/0x50
 [<c04745f2>] ? hrtimer_try_to_cancel+0x32/0xb0
 [<c0474681>] ? hrtimer_cancel+0x11/0x20
 [<c081807d>] ? do_nanosleep+0x8d/0xc0
 [<c0474747>] ? hrtimer_nanosleep+0xb7/0x150
 [<c066d9d9>] ? tty_write+0x1c9/0x230
 [<c0473780>] ? hrtimer_wakeup+0x0/0x20
 [<c04745b0>] ? hrtimer_start_range_ns+0x20/0x30
 [<c0474838>] ? sys_nanosleep+0x58/0x60
 [<c04098fb>] ? sysenter_do_call+0x12/0x28
[drm:drm_fb_helper_panic] *ERROR* panic occurred, switching back to text console

machine: ibm-hs21-04.lab.bos.redhat.com
distro: RHEL6.0-20100603.1

Version-Release number of selected component (if applicable):
2.6.32-33.el6

How reproducible:
unknown, first time seen
Comment 1 Aristeu Rozanski 2010-06-16 18:03:42 EDT
Log: http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=14785818
Comment 3 RHEL Product and Program Management 2010-06-16 19:13:00 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Andy Gospodarek 2010-06-16 21:08:35 EDT

*** This bug has been marked as a duplicate of bug 601066 ***

Note You need to log in before you can comment on or make changes to this bug.