Bug 60493 - Installer crash after formating partitions
Installer crash after formating partitions
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 11:19 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 01:24:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-02-28 11:19:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011228

Description of problem:
Hi,

I have some troubles with a Kickstart Installation of 7.2. I have some problems
partitioning the harddrive. When I choose the option --grow for one partition in
my ks.cfg.

Here is my ks.cfg file:

#Generated by Kickstart Configurator
lang de_DE
langsupport de_DE
keyboard de-latin1
#Probe for Mouse
mouse
timezone --utc Europe/Berlin
rootpw --iscrypted $1$^Y|H}QV~$//TIhK4GEyWctLLCE1IUr/
reboot
text
bootloader --useLilo --linear --location=mbr
install
url --url ftp://ftp.space.net/pub/linux/redhat/releases/7.2/en/os/i386/
clearpart --all
part /boot --size 50 --ondisk sda
part /usr --size 4000 --ondisk sda
part /home --size 1000 --ondisk sda
part / --size 256  --ondisk sda
part /var --size 5000 --grow --ondisk sda
part  swap --size 256
network --bootproto dhcp
auth  --useshadow  --enablemd5
firewall --disabled
#Do not configure the X Window System
skipx
%packages
wget
openssh
openssh-clients
openssh-server

The Installer crashes after formatting the partitions. With some errors like:

/usr/sbin/probe: error while loading shared librariers: /lib/libc.so.6: cannot
read file data: Error 21 install exited abnormally -- received signal 11.....

If I choose in the kickstart file the interactive mode everything works fine,
but the problem is i dont want to see everytime my configuration :) it should
work absolutely without looking at the server.

My opinion is that the installer has some problems creating an extended
partition, because if I choose for /var a smaller size, so there has no extended
to be created it works fine too.

My System is:
Celeron 500
Adaptec 2940 Scsi Controller
IBM 9 GB UW hard disk
256 Mb ram

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.everytime i use the --grow option
2.
3.
	

Additional info:
Comment 1 Jeremy Katz 2002-03-01 01:24:42 EST
How are you booting your install?  Is ramdisk_size=7192 being appended to the
kernel command line?
Comment 2 Need Real Name 2002-03-01 05:07:17 EST
Hi,

I have tried the option with ramdisk and it helped. Arg I think i have tried an
older howto. My howto on www.linuxdoc.org says you can add this lines to your
syslinux.cfg

  default ks
  prompt 0
  label ks
    kernel vmlinuz
    append ks=floppy initrd=initrd.img


and there is no ramdisk parameter :(.

Thanks for you help.

Greetings Markus

Note You need to log in before you can comment on or make changes to this bug.