Bug 604945 - sendmail local delivery assertion failure when using MatchGECOS=True and nss lookups on ldap
Summary: sendmail local delivery assertion failure when using MatchGECOS=True and nss ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nss_ldap   
(Show other bugs)
Version: 4.8
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Nalin Dahyabhai
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 04:45 UTC by Jatin Nansi
Modified: 2018-11-14 20:07 UTC (History)
8 users (show)

Fixed In Version: nss_ldap-253-15.el4
Doc Type: Bug Fix
Doc Text:
The "endpwent" function called ldap query with the NULL handle and the parent process crashed. With this update, the handle is used only if it is valid.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 14:02:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (390 bytes, patch)
2010-07-09 12:41 UTC, Jaroslav Škarvada
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0239 normal SHIPPED_LIVE nss_ldap bug fix update 2011-02-15 16:35:01 UTC

Comment 7 Jaroslav Škarvada 2010-07-09 12:37:31 UTC
As it hangs in endpwent I do not recognize this as sendmail fault. The problem is that while closing the ldap connection in endpwent it calls the ldap_result with NULL handle and this call causes the hang. Commenting the endpwent call in sendmail doesn't solve the matter of this problem. I think that it should be fixed in nss_ldap, because it is known problem and there also exists upstream bugzilla for it:

http://bugzilla.padl.com/show_bug.cgi?id=350

Comment 8 Jaroslav Škarvada 2010-07-09 12:41:15 UTC
Created attachment 430663 [details]
Proposed patch

Slightly modified patch from upstream bugzilla. This patch resolves the problem for me. Same patch is used in all later versions of nss_ldap.

Comment 9 Jaroslav Škarvada 2010-07-09 12:46:21 UTC
I propose reassigning this to nss_ldap and using patch from comment 8.

Comment 14 Eva Kopalova 2011-02-09 13:17:10 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The "endpwent" function called ldap query with the NULL handle and the parent process crashed. With this update, the handle is used only if it is valid.

Comment 15 errata-xmlrpc 2011-02-16 14:02:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0239.html


Note You need to log in before you can comment on or make changes to this bug.