Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 604947 - wrong printer driver selected by default for HP Color Laserjet 2600n
wrong printer driver selected by default for HP Color Laserjet 2600n
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 665829 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 00:54 EDT by Alex Deucher
Modified: 2011-01-03 10:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 12:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lpinfo -l -v (1.84 KB, patch)
2010-06-17 11:01 EDT, Alex Deucher
no flags Details | Diff
troubleshoot.txt (156.87 KB, patch)
2010-06-17 11:31 EDT, Alex Deucher
no flags Details | Diff

  None (edit)
Description Alex Deucher 2010-06-17 00:54:00 EDT
Description of problem:
When I install the printer the selected driver is hplip which does not work with this printer.  The foo2hp driver should be selected instead.

How reproducible:
Always

Steps to Reproduce:
1. Add printer for HP Color Laserjet 2600n
2. hplip is selected as the driver.

Actual results:
Printing does not work.

Expected results:
Printing works.

Additional info:
The foo2hp driver works perfectly.
Comment 1 Jiri Popelka 2010-06-17 08:20:41 EDT
I think the basic problem here is that 2600n
needs a proprietary plug-in to work with hplip.

The 'hp-plugin' program will attempt to install the proprietary plug-in.

Can you also show me what does the following command
su -c "lpinfo -l -v"
Comment 2 Alex Deucher 2010-06-17 11:01:36 EDT
Created attachment 424848 [details]
lpinfo -l -v

This is with foo2hp installed.  Also, FWIW, I'm using the jetdirect port over the network rather than attaching locally.
Comment 3 Jiri Popelka 2010-06-17 11:19:08 EDT
Can you install the proprietary plugin (with 'hp-plugin' program),
add the printer to use hplip driver (as in your description of this bug)
and try to print a test page from printing troubleshooter.
https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter

Add then the troubleshoot.txt to this bug report. thanks
Comment 4 Alex Deucher 2010-06-17 11:31:08 EDT
Created attachment 424860 [details]
troubleshoot.txt

Attached.
Comment 5 Jiri Popelka 2010-06-18 09:35:13 EDT
There's IPP printer state reason 'hplip.plugin-error',
which means that proprietary plugin is still missing.

Alex, did you installed that plugin ?
Comment 6 Alex Deucher 2010-06-21 09:14:42 EDT
Yes.  I ran hp-plugin and it downloaded and installed something.  When I run it again it asks if it wants me to re-install.  FWIW, I'm on x86-64 perhaps the proprietary plugins are x86 only?
Comment 7 Jiri Popelka 2010-07-07 12:00:47 EDT
Strange.
There's
D [17/Jun/2010:11:27:38 -0400] [Job 5] prnt/hpcups/HPCupsFilter.cpp 413: m_Job initialization failed with error = 48

which also indicates that the plugin is missing.
the 48 value = PLUGIN_LIBRARY_MISSING //!< a required plugin (dynamic) library is missing
Comment 8 Alex Deucher 2010-07-07 12:11:54 EDT
Is there some way the hp-plugin thing could be automated?  It's not really intuitive to manually run hp-plugin (which requires Qt which isn't installed by default so I had to run it in text mode (-i)).  Also, is there some lib or app I should look for to make sure it's installed correctly?  Here appear to be a bunch of Qt hp utilites:
hp-align            hp-fab              hp-info             hp-mkuri            hp-query            hp-timedate
hp-clean            hp-faxsetup         hp-levels           hp-plugin           hp-scan             hp-unload
hp-colorcal         hp-firmware         hp-linefeedcal      hp-pqdiag           hp-sendfax          hp-wificonfig
hpcups-update-ppds  hpftodit            hp-makecopies       hp-printsettings    hp-setup            
hp-devicesettings   hpijs               hp-makeuri          hp-probe            hp-testpage
Comment 9 Jiri Popelka 2010-07-07 12:49:39 EDT
Usually when I need to check whether a package is installed correctly, I use 'rpm -V package'. So you can check the hplip packages with
'rpm -V hplip hpijs hplip-gui hplip-libs hplip-common'

But this proprietary plugin stuff downloads something somewhere. I'm afraid I can't help you in this case.

And to the automatic plugin installation question ... see bug #500480, comment#1
Comment 10 Alex Deucher 2010-07-07 13:15:13 EDT
So then I guess my question is, if you don't support hplip for printers that require proprietary plugins, why not just use open alternatives like foo2hp?  At least printers would work out of the box rather than silently failing.
Comment 11 Jiri Popelka 2010-07-08 06:15:29 EDT
(In reply to comment #10)
> At least printers would work out of the box rather than silently failing.    

There should be a notification explaining what's wrong
when you try to print on proprietary plugin requiring printer (and no plugin is installed). See bug #531872.
Comment 12 Tim Waugh 2010-07-12 12:20:20 EDT
(In reply to comment #10)
> So then I guess my question is, if you don't support hplip for printers that
> require proprietary plugins, why not just use open alternatives like foo2hp? 

The Fedora project cannot ship foo2hp due to patent concerns.
Comment 13 Jiri Popelka 2011-01-03 10:20:02 EST
*** Bug 665829 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.