Bug 60498 - split tcl man pages out of tcl package
split tcl man pages out of tcl package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 11:59 EST by Ben LaHaise
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version: 8.3.5-90
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-04 17:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben LaHaise 2002-02-28 11:59:42 EST
The tcl man pages contain many entries that hit on common searches.  For those
of us who never use tcl, it would be nice to remove them.  Removing the tcl
package itself is not an option as the dependancy chain hits critical packages
like db-utils, so I'd ask that the tcl manpages be split out of tcl package
instead.
Comment 1 Need Real Name 2002-05-03 00:15:26 EDT
I would really like to see this too.  Having all those man pages makes "man -k"
really annoying to use.
Comment 2 Bill Huang 2002-06-09 23:15:32 EDT
Most of the packages contain its packages and man pages together,it is a nature
consideration.To split the man pages out of the package means that there will be
one more package added and the added man package is just for you to be able to
remove it.I don't think the request is not reasonable,but at least it is not a bug.
Comment 3 Ben LaHaise 2002-06-09 23:55:00 EDT
tcl is a mandatory part of the system due to dependancies.  I do not want tcl
manpages installed as a non-tcl user.  Please split the package out.  This was
filed as an enhancement bug.
Comment 4 Jens Petersen 2003-06-27 02:13:15 EDT
In the next build (8.3.5-90 or later) the tcl manpages should now be in a new
tcl-devel and the tk ones in a new tk-devel subpackage.
Comment 5 Jens Petersen 2003-07-04 17:54:46 EDT
Fixed packages should be in 8.3.5-90.1 in rawhide shortly.
Could you please check that they are ok?

Note You need to log in before you can comment on or make changes to this bug.