This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 60504 - gcc: "gcc.c-torture/execute/ieee/hugeval.c execution, -O0" fails
gcc: "gcc.c-torture/execute/ieee/hugeval.c execution, -O0" fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 13:18 EST by Christopher Holmes
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 09:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Holmes 2002-02-28 13:18:24 EST
Description of Problem:

	gcc: "gcc.c-torture/execute/ieee/hugeval.c execution, -O0" fails

Version-Release number of selected component (if applicable):

	gcc-2.96-101.src.rpm

How Reproducible:

	always

Steps to Reproduce:

1. rpm -i gcc-2.96-101.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpm -ba gcc.spec
4. cd /usr/src/redhat/BUILD/gcc-2.96-20000731/obj-alpha-redhat-linux
5. make -k check
6. review gcc/testsuite/gcc.log

Actual Results:

Executing on host:
/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-alpha-redhat-linux/gcc/xgcc
-B/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-alpha-redhat-linux/gcc/
/usr/src/redhat/BUILD/gcc-2.96-20000731/gcc/testsuite/gcc.c-torture/execute/ieee/hugeval.c 
-w  -O0  -ffloat-store  -lm   -o
/usr/src/redhat/BUILD/gcc-2.96-20000731/obj-alpha-redhat-linux/gcc/testsuite/hugeval.x0   
(timeout = 300)
PASS: gcc.c-torture/execute/ieee/hugeval.c compilation,  -O0 
FAIL: gcc.c-torture/execute/ieee/hugeval.c execution,  -O0 

Expected Results:

PASS: gcc.c-torture/execute/ieee/hugeval.c execution,  -O0 

Additional Information:

	Expected results achieved on intel RedHat7.2
Comment 1 Beth Uptagrafft 2002-04-24 14:05:52 EDT
Fixed in next release. Test was failing because the testing environment was not 
passing the -mieee flag to the compiler when building.

Note You need to log in before you can comment on or make changes to this bug.