Bug 605224 - [RHEL6] [Kernel] [KVM] WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+
[RHEL6] [Kernel] [KVM] WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+
Status: CLOSED DUPLICATE of bug 606131
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
http://rhts.redhat.com/cgi-bin/rhts/t...
:
Depends On:
Blocks: 562808
  Show dependency treegraph
 
Reported: 2010-06-17 09:15 EDT by Jeff Burke
Modified: 2010-07-08 12:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 12:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2010-06-17 09:15:39 EDT
Description of problem:
 When running the kernel tests for the latest kernel. We hit the following error. The KVM guests failed to start properly.

Version-Release number of selected component (if applicable):
 2.6.32-36.el6

How reproducible:
 Unknown

Steps to Reproduce:
1. Using the RHEL6.0-20100603.1 x86_64 install the system. Then upgrade kernel. Install a kvm guest. The error was seen in the host dmesg file.
  
Actual results:

------------[ cut here ]------------
WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Not tainted)
Hardware name: ProLiant SL170z G6  
Modules linked in: tun(U) nls_utf8(U) nfs(U) lockd(U) fscache(U) nfs_acl(U) auth_rpcgss(U) sit(U) tunnel4(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) igb(U) iTCO_wdt(U) serio_raw(U) dca(U) i7core_edac(U) iTCO_vendor_support(U) edac_core(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) crc_t10dif(U) ata_generic(U) pata_acpi(U) ata_piix(U) dm_mod(U) [last unloaded: microcode]
Pid: 15003, comm: qemu-kvm Not tainted 2.6.32-36.el6.x86_64 #1
Call Trace:
 [<ffffffff8106a703>] warn_slowpath_common+0x83/0xc0
 [<ffffffff8106a754>] warn_slowpath_null+0x14/0x20
 [<ffffffffa01a06c0>] handle_ept_misconfig+0x220/0x240 [kvm_intel]
 [<ffffffffa01a367d>] vmx_handle_exit+0xbd/0x240 [kvm_intel]
 [<ffffffffa016c5c7>] kvm_arch_vcpu_ioctl_run+0x3c7/0xd90 [kvm]
 [<ffffffffa01581b2>] kvm_vcpu_ioctl+0x522/0x670 [kvm]
 [<ffffffff810a49a2>] ? do_futex+0x682/0xb00
 [<ffffffff8117c8a2>] vfs_ioctl+0x22/0xa0
 [<ffffffff8117cd6a>] do_vfs_ioctl+0x3aa/0x580
 [<ffffffff8117cfc1>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
---[ end trace 10baef7664a7586a ]---

Expected results:
Should be able to install and boot kvm guests.

Additional info:
Here is the entire dmesg at the start of the test:
vnet0: no IPv6 routers present
kvm: 15512: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 15512: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 15512: cpu0 unimplemented perfctr wrmsr: 0xc1 data 0xffe17b70
kvm: 15512: cpu0 unimplemented perfctr wrmsr: 0x186 data 0x530079
kvm: 15512: cpu1 unimplemented perfctr wrmsr: 0xc1 data 0x0
kvm: 15512: cpu1 unimplemented perfctr wrmsr: 0x186 data 0x130079
kvm: 15512: cpu1 unimplemented perfctr wrmsr: 0xc1 data 0xffe17b70
kvm: 15512: cpu1 unimplemented perfctr wrmsr: 0x186 data 0x530079
vnet1: no IPv6 routers present
br0: port 2(vnet0) entering forwarding state
br0: port 3(vnet1) entering forwarding state
EPT: Misconfiguration.
EPT: GPA: 0x2fcee000
ept_misconfig_inspect_spte: spte 0x9b53d007 level 4
ept_misconfig_inspect_spte: spte 0x9b549007 level 3
ept_misconfig_inspect_spte: spte 0x11fe6c0f5 level 2
ept_misconfig_inspect_spte: rsvd_bits = 0x6c000
------------[ cut here ]------------
WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Not tainted)
Hardware name: ProLiant SL170z G6  
Modules linked in: tun(U) nls_utf8(U) nfs(U) lockd(U) fscache(U) nfs_acl(U) auth_rpcgss(U) sit(U) tunnel4(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) igb(U) iTCO_wdt(U) serio_raw(U) dca(U) i7core_edac(U) iTCO_vendor_support(U) edac_core(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) crc_t10dif(U) ata_generic(U) pata_acpi(U) ata_piix(U) dm_mod(U) [last unloaded: microcode]
Pid: 15003, comm: qemu-kvm Not tainted 2.6.32-36.el6.x86_64 #1
Call Trace:
 [<ffffffff8106a703>] warn_slowpath_common+0x83/0xc0
 [<ffffffff8106a754>] warn_slowpath_null+0x14/0x20
 [<ffffffffa01a06c0>] handle_ept_misconfig+0x220/0x240 [kvm_intel]
 [<ffffffffa01a367d>] vmx_handle_exit+0xbd/0x240 [kvm_intel]
 [<ffffffffa016c5c7>] kvm_arch_vcpu_ioctl_run+0x3c7/0xd90 [kvm]
 [<ffffffffa01581b2>] kvm_vcpu_ioctl+0x522/0x670 [kvm]
 [<ffffffff810a49a2>] ? do_futex+0x682/0xb00
 [<ffffffff8117c8a2>] vfs_ioctl+0x22/0xa0
 [<ffffffff8117cd6a>] do_vfs_ioctl+0x3aa/0x580
 [<ffffffff8117cfc1>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
---[ end trace 10baef7664a7586a ]---
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
.
.
.
.
SELinux: initialized (dev 0:2e, type nfs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
EPT: Misconfiguration.
EPT: GPA: 0x1fbd6000
ept_misconfig_inspect_spte: spte 0x9b51b007 level 4
ept_misconfig_inspect_spte: spte 0x4f400007 level 3
ept_misconfig_inspect_spte: spte 0x15e97e0f5 level 2
ept_misconfig_inspect_spte: rsvd_bits = 0x17e000
------------[ cut here ]------------
WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Tainted: G        W )
Hardware name: ProLiant SL170z G6  
Modules linked in: tun(U) nls_utf8(U) nfs(U) lockd(U) fscache(U) nfs_acl(U) auth_rpcgss(U) sit(U) tunnel4(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) igb(U) iTCO_wdt(U) serio_raw(U) dca(U) i7core_edac(U) iTCO_vendor_support(U) edac_core(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) crc_t10dif(U) ata_generic(U) pata_acpi(U) ata_piix(U) dm_mod(U) [last unloaded: microcode]
Pid: 15534, comm: qemu-kvm Tainted: G        W  2.6.32-36.el6.x86_64 #1
Call Trace:
 [<ffffffff8106a703>] warn_slowpath_common+0x83/0xc0
 [<ffffffff8106a754>] warn_slowpath_null+0x14/0x20
 [<ffffffffa01a06c0>] handle_ept_misconfig+0x220/0x240 [kvm_intel]
 [<ffffffffa01a367d>] vmx_handle_exit+0xbd/0x240 [kvm_intel]
 [<ffffffffa016c5c7>] kvm_arch_vcpu_ioctl_run+0x3c7/0xd90 [kvm]
 [<ffffffffa01581b2>] kvm_vcpu_ioctl+0x522/0x670 [kvm]
 [<ffffffff810a49a2>] ? do_futex+0x682/0xb00
 [<ffffffff8117c8a2>] vfs_ioctl+0x22/0xa0
 [<ffffffff8117cd6a>] do_vfs_ioctl+0x3aa/0x580
 [<ffffffff8117cfc1>] sys_ioctl+0x81/0xa0
 [<ffffffff81013172>] system_call_fastpath+0x16/0x1b
---[ end trace 10baef7664a7586b ]---
Comment 3 RHEL Product and Program Management 2010-06-17 09:33:48 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Don Dutile 2010-07-06 13:19:17 EDT
Did you update qemu-kvm & libvirt pkgs as well?
what are their revs?

assuming you are installing -36 guest, but to be sure, what are you installing?
Comment 5 Jeff Burke 2010-07-06 13:32:37 EDT
Q: Did you update qemu-kvm & libvirt pkgs as well?
A: No, The qemu-kvm & libvirt are the ones that are in the RHEL6.0-20100603.1 tree at the time of the compose. Looks like 
- libvirt-0.8.1-7.el6.src.rpm
- qemu-kvm-0.12.1.2-2.68.el6.src.rpm

Q: Assuming you are installing -36 guest
A: No the install was using the kernel that was in the RHEL6.0-20100603.1 tree at the time of the compose. Looks like 
- kernel-2.6.32-33.el6.src.rpm

Q: But to be sure, what are you installing?
?: Are you asking for guest options? or install tree? Both can be found in the URL section of this BZ or in the Steps to reproduce of section the BZ"
Comment 6 Don Dutile 2010-07-06 15:48:13 EDT
The stack trace is for a VMEXIT with an invalid shadow page table / ept error.

fwd'd to ept-misconfig() developer to see if they can suggest source of
misconfiguration.
Comment 8 Andrea Arcangeli 2010-07-08 09:39:01 EDT
Did you use KSM? We thought it was only reproducible with KSM but maybe not.
Comment 9 Don Dutile 2010-07-08 12:25:19 EDT
Marked as dup of 606131 per Marcelo Tosatti's request.

*** This bug has been marked as a duplicate of bug 606131 ***

Note You need to log in before you can comment on or make changes to this bug.