Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605285 - Obsoletes statement isn't working
Obsoletes statement isn't working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 11:06 EDT by Rick L Vinyard Jr
Modified: 2011-02-18 14:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 14:41:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick L Vinyard Jr 2010-06-17 11:06:14 EDT
The obsoletes statement in the spec isn't getting rid of eclipse-cdt-mylyn packages from F12 on systems upgraded to F13.

As a result this is causing system updates to fail.

Here is the current obsoletes line:
Obsoletes: eclipse-cdt-mylyn <= 1:6.0.1-5.fc13

Perhaps the fc13 is too specific, as the package that needed to be obsoleted was eclipse-cdt-mylyn-6.0.1-8.fc12.

My solution was to yum erase it manually, but not all users may be comfortable doing that.
Comment 1 Rick L Vinyard Jr 2010-06-17 11:20:37 EDT
Never mind... it looks like the version in the obsoletes line is too old.
Comment 2 Rick L Vinyard Jr 2010-06-17 11:21:48 EDT
Just a clarificaiton... "never mind" referred to my suggestion regarding the fc version. The bug is in the obsoleted version.
Comment 3 Fedora Admin XMLRPC Client 2010-09-01 09:54:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Andrew Overholt 2010-09-01 11:09:24 EDT
Alex/Jeff, please take a look here.
Comment 5 Jeff Johnston 2010-09-01 16:36:06 EDT
A fix has been made to f13, f14, and rawhide to use an epoch of 2 to handle the eclipse-cdt-mylyn provides and obsoletes.  This will force the obsoletion of any f12 eclipse-cdt-mylyn package.
Comment 6 Alexander Kurtakov 2010-09-01 16:48:25 EDT
Why do we need the epoch 2?
Just changing the Obsoletes to be 
Obsoletes: eclipse-cdt-mylyn <= 1:6.0.1-8.fc12 should work, right?
Comment 7 Jeff Johnston 2010-09-01 17:15:52 EDT
(In reply to comment #6)
> Why do we need the epoch 2?
> Just changing the Obsoletes to be 
> Obsoletes: eclipse-cdt-mylyn <= 1:6.0.1-8.fc12 should work, right?

it would work too, I could optimally set it to 7.0.0 which is definitely out of range for f12 and is already passed by f13/f14/rawhide if you would prefer.  This is only meaningful should it get put back into eclipse-cdt in the future and IMO this is extremely unlikely to ever happen.
Comment 8 Alexander Kurtakov 2011-02-18 01:51:13 EST
Jeff, this is fixed long ago, right? Can we close it?
Comment 9 Jeff Johnston 2011-02-18 14:41:30 EST
(In reply to comment #8)
> Jeff, this is fixed long ago, right? Can we close it?

Yes, closing now.

Note You need to log in before you can comment on or make changes to this bug.