Bug 605337 - Zarafa package does not include zarafa-licensed
Summary: Zarafa package does not include zarafa-licensed
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: zarafa (Show other bugs)
(Show other bugs)
Version: 12
Hardware: All Linux
low
urgent
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 16:39 UTC by Derek Atkins
Modified: 2010-06-17 20:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 20:54:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Atkins 2010-06-17 16:39:22 UTC
Description of problem:

I tried to connect to zarafa using an outlook client.  The community edition is supposed to allow 3 outlook clients, but it requires zarafa-licensed to accept them.  However the Fedora packages do not ship zarafa-licensed, which means you cannot use Outlook against a fedora package installed zarafa server!  When you do, outlook complains:

Cannot start Zarafa client because the server was unable to contact the zarafa-licensed license server.  Please consult your system administrator.

Version-Release number of selected component (if applicable):

zarafa-6.30.14-1.fc12.i686

How reproducible:

100%

Steps to Reproduce:
1. Install and configure Zarafa normally
2. Install the Zarafa client on Windows
3. Try to connect to the Zarafa server as per the Zarafa documentation.
  
Actual results:

As above.  There is no zarafa-licensed service installed on the system, and as a result I cannot connect my outlook client.

Expected results:

I should have all the zarafa software in the packages so I can use all the features!


Additional info:

Comment 1 Derek Atkins 2010-06-17 16:40:15 UTC
Oh, forgot to add this link:  http://forums.zarafa.com/viewtopic.php?f=9&t=1007

Comment 2 Robert Scheck 2010-06-17 20:54:12 UTC
Derek, thanks for your report.

Unfortunately your report is not a bug for several reasons: First of all, the
zarafa-licensed package includes only proprietary software which doesn't match
with the foundations of the Fedora Project. Second thing is, that even I would
take the proprietary zarafa-licensed, it wouldn't technically work on Fedora,
because there are many ABI incompatibilities and some soname/soversion changes
happened in the meantime in Fedora.

The most important thing is: Fedora is only shipping the Open Source Edition
of the Zarafa Collaboration Platform and NOT the Community Edition. The Open
Source Edition contains only the Zarafa software, which is available as Open
Source Software. The Community Edition includes the Open Source Edition plus
the proprietary features like zarafa-licensed, zarafa-backup, zarafa-restore,
zarafa-webaccess-muc etc.

With short words: Community Edition != Open Source Edition


Note You need to log in before you can comment on or make changes to this bug.