Bug 605354 - compound_lock irq deadlock
Summary: compound_lock irq deadlock
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Andrea Arcangeli
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 606398 607430 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 17:35 UTC by Andrea Arcangeli
Modified: 2010-07-02 19:21 UTC (History)
7 users (show)

Fixed In Version: kernel-2.6.32-37.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 19:21:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrea Arcangeli 2010-06-17 17:35:24 UTC
Description of problem: irq deadlock in compound_lock

How reproducible: run oracle in KVM guest with Transparent Hugepage Support enabled

Comment 2 RHEL Product and Program Management 2010-06-17 17:53:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Andrea Arcangeli 2010-06-17 17:53:52 UTC
fixes posted on rhkernel-list with Message-Id: <patchbomb.1276796772@v2.random>

Comment 4 Andrea Arcangeli 2010-06-17 18:02:18 UTC
submitted a build with all fixes on top of -36 kernel here:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2527470

Comment 6 Andrea Arcangeli 2010-06-21 15:04:42 UTC
*** Bug 606398 has been marked as a duplicate of this bug. ***

Comment 7 Aristeu Rozanski 2010-06-21 21:19:40 UTC
Patch(es) available on kernel-2.6.32-37.el6

Comment 10 Amos Kong 2010-06-25 10:11:51 UTC
*** Bug 607430 has been marked as a duplicate of this bug. ***

Comment 11 Amos Kong 2010-06-30 04:46:55 UTC
This bug is easy to be reproduced by launching a kvm guest and do some general operation.

It could not be reproduced with kernel-2.6.32-37.el6
So move it to VERIFIED state

Comment 12 releng-rhel@redhat.com 2010-07-02 19:21:00 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.