Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605358 - udev regression for /dev/live symlink
udev regression for /dev/live symlink
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Alan Pevec
Virtualization Bugs
: Reopened
Depends On: 605356
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 13:42 EDT by Joey Boggs
Modified: 2016-04-26 11:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt-node-1.9.3-4.gitf53c39c.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 605356
Environment:
Last Closed: 2010-11-11 09:52:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 RHEL Product and Program Management 2010-06-17 13:53:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Alan Pevec 2010-06-28 03:45:24 EDT

*** This bug has been marked as a duplicate of bug 605356 ***
Comment 5 Alan Pevec 2010-06-28 18:05:21 EDT
reopened for the temp
Comment 6 Alan Pevec 2010-06-28 18:05:42 EDT
...workaround:
--- a/scripts/ovirt-early
+++ b/scripts/ovirt-early
@@ -298,6 +298,15 @@ start_ovirt_early () {
 
     for i in $(cat /proc/cmdline); do
         case $i in
+            root=live:CDLABEL=*)
+            set -x
+            # workaround for bz#605356
+            blkid /dev/sr*
+            label=${i#root=live:CDLABEL=}
+            mount -r -L $label /live
+            ln -s $(blkid -L $label) /dev/live
+            set +x
+            ;;
             BOOTIF=*)
             i=${i#BOOTIF=}
             case "$i" in
Comment 10 XinSun 2010-08-24 05:03:31 EDT
Check this bug on rhevh6.0-2.3 snapshot12, do follow steps:

On a snap12 LiveCD

[root@host1]# ls -l /dev/live
lrwxrwxrwx. 1 root root 3 Aug 24 07:38 /dev/live -> sr0

[root@host1 dev]# blkid /dev/sr0
/dev/sr0: LABEL="rhev-hypervisor" TYPE="iso9660" 

[root@host1 dev]# ls -l /dev/disk/by-label
total 0
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 CONFIG -> ../../dm-7
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 DATA -> ../../dm-9
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 LOGGING -> ../../dm-8
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 Root -> ../../dm-3
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 RootBackup -> ../../dm-4
lrwxrwxrwx. 1 root root 10 Aug 24 07:29 SWAP -> ../../dm-6
lrwxrwxrwx. 1 root root 11 Aug 24 07:29 _rhev-hypervisor -> ../../loop3
lrwxrwxrwx. 1 root root  9 Aug 24 07:39 rhev-hypervisor -> ../../sr0

So change this bug's status to verified
Comment 11 releng-rhel@redhat.com 2010-11-11 09:52:46 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.