Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 605364 - Backport changes from openchange svn
Backport changes from openchange svn
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openchange (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
Depends On:
Blocks: 605369
  Show dependency treegraph
 
Reported: 2010-06-17 14:11 EDT by Milan Crha
Modified: 2010-11-15 12:10 EST (History)
4 users (show)

See Also:
Fixed In Version: openchange-0.9-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:33:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2010-06-17 14:11:06 EDT
There are some known issues with openchange 0.9 which cannot be fixed otherwise then in openchange (the other part using openchange is evolution-mapi). From the most significant I would name:
a) unicode support is not finished in 0.9 resulting in (for example):
   - lost letters from strings
   - cannot send messages with unicode letters in subject
b) support for particular property types is not done at all in 0.9
   - PT_DOUBLE - no percent complete in tasks
   - PT_MV_BINARY - for distribution lists (address book)
There are more which I cannot recall right now, but the point is that with these not working (especially from a)) customers would not use evolution-mapi properly.
(Note that some changes are also needed on evolution-mapi side to have this working properly.)
Comment 2 RHEL Product and Program Management 2010-06-17 14:33:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Milan Crha 2010-06-17 14:36:55 EDT
I forgot to mention, these changes are including openchange API changes, but as evolution-mapi is the only package linking against it (I'm just about to file the bug and set it as depending on this one), then that shouldn't be a problem.
Comment 4 Milan Crha 2010-06-25 05:00:17 EDT
Patch committed to openchange-0.9-7.el6. It fixes unicode support and some property types. I do not have any exact steps for testing, because this is a library. It can be tested with evolution-mapi-0.28.3-5, which requires this package.
Comment 7 releng-rhel@redhat.com 2010-11-15 09:33:30 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.