Bug 605371 - gfs2_convert manpage and documentation updates
gfs2_convert manpage and documentation updates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Global_File_System_2 (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On: 588374 594510 601315
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 14:47 EDT by Steven J. Levine
Modified: 2010-11-11 10:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 594510
Environment:
Last Closed: 2010-11-11 10:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2010-06-17 14:47:19 EDT
Cloning this bug for RHEL 6.0 because, as per bug 601315, the info applies to RHEL 6.0 as well.


+++ This bug was initially created as a clone of Bug #594510 +++

Cloning the bug as a documentation bug to assign to myself for updating the GFS2 manual for RHEL 5.6.



+++ This bug was initially created as a clone of Bug #588374 +++

The recent fixes/updates to gfs2_convert changes its behavior in a few cases such as handling of CDPNs, converting full filesystems etc. This needs to be documented in the manpage and the gfs2-utils documentation.

--- Additional comment from slevine@redhat.com on 2010-05-20 16:11:41 EDT ---

Abhi:

Just for reference (to keep this info attached to this bug), here's the current RHEL 5 gfs2_convert documentation. I'll need to run it by you for review.

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Global_File_System_2/gfs_upgrade.html

Here's the RHEL 6 version (for completeness's sake):

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Global_File_System_2/gfs_upgrade.html

--- Additional comment from adas@redhat.com on 2010-05-20 16:37:46 EDT ---

Created an attachment (id=415505)
manpage update to document recent changes to gfs2_convert

--- Additional comment from slevine@redhat.com on 2010-05-20 17:23:05 EDT ---

Abhi: 

Is this for 6.0 as well?

I'll file a separate bug to update the gfs2 document for 5.6, to add these additional caveats.

I'm not sure if you were looking for an edit of the updates to the man page, or just feedback on the clarity of the information. It all seems clear enough to me, but I might slightly change these wordings (although they are not incorrect, per se):

> It is possible to reissue the gfs2_convert command on such a filesystem to
> completely convert it to GFS2.

The "it is possible to" is a little unclear. It may be possible to reissue the command, but is that what we're saying is the procedure?  Maybe something like:

  When this occurs, reissue the gfs2_convert command on the partially converted
  filesystem to complete the conversion process.

> The administrator can use bind mounts on these directories to get
> the same effect of CDPNs.

Very tiny, but I'd say "as CDPNs" rather than "of CDPNs".

As I say, I'll open a separate bug for my document for 5.6. If this information applies to 6.0, I'll open a bug for that as well.
Comment 2 RHEL Product and Program Management 2010-06-17 15:13:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Steve Whitehouse 2010-07-12 07:07:01 EDT
What is left to do here? Just the docs, or does the man page still need updating as well?
Comment 4 Steven J. Levine 2010-07-23 14:05:09 EDT
Steve:

Abhi updated the man page, so that seems to be done, and I'm updating the docs now. Abhi reviewed my first pass and he'll be providing me with updated command output. So this isn't complete yet, but almost.
Comment 5 Steven J. Levine 2010-07-23 14:05:37 EDT
[Forgot to clear NEEDINFO flag...]
Comment 6 Steven J. Levine 2010-10-12 16:37:05 EDT
The RHEL 6 version of the GFS2 manual includes the updated information about the gfs2_convert command. This has been checked in to the SVN repository and posted on the review server so I am marking this as MODIFIED.
Comment 8 Michael Doyle 2010-10-15 02:10:35 EDT
Verified it is in Red_Hat_Enterprise_Linux-Global_File_System_2-6-en-US-7-13.
Comment 9 releng-rhel@redhat.com 2010-11-11 10:29:47 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.