This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 605446 - [abrt] crash in pdfedit-0.4.5-1.fc13: SIGABRT: observer::ObserverHandler<pdfobjects::IProperty>::unregisterObserver(boost::shared_ptr<observer::IObserver<pdfobjects::IProperty> const> const&) ()
[abrt] crash in pdfedit-0.4.5-1.fc13: SIGABRT: observer::ObserverHandler<pdfo...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pdfedit (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
abrt_hash:9352fc0f0c2ac2874fb8adb89bc...
:
: 702453 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 20:16 EDT by Andrew Pitonyak
Modified: 2011-05-05 17:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-05 17:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (9.92 KB, text/plain)
2010-06-17 20:16 EDT, Andrew Pitonyak
no flags Details

  None (edit)
Description Andrew Pitonyak 2010-06-17 20:16:03 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: pdfedit Essential_Woodworker_copy.pdf
component: pdfedit
crash_function: raise
executable: /usr/bin/pdfedit
global_uuid: 9352fc0f0c2ac2874fb8adb89bcd81c72bddb09f
kernel: 2.6.33.5-112.fc13.x86_64
package: pdfedit-0.4.5-1.fc13
rating: 4
reason: Process /usr/bin/pdfedit was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
How to reproduce: Selected and deleted object
Comment 1 Andrew Pitonyak 2010-06-17 20:16:09 EDT
Created attachment 424981 [details]
File: backtrace
Comment 2 Orion Poplawski 2010-11-01 16:54:23 EDT
#1  0x000000352ca34185 in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x7fff4ae78ef0, 
            sa_sigaction = 0x7fff4ae78ef0}, sa_mask = warning: can't find linker symbol for virtual table for `(null)' value
{__val = {228382075744, 
              140734450077448, 4294967296, 228486812616, 140125513588736, 
              228381977424, 140125513589960, 140734450077608, 4294967295, 
              228494083968, 1, 228494082600, 0, 4294967295, 12564016, 0}}, 
          sa_flags = 744546048, sa_restorer = 0x3500000001}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00000035332be8cd in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:93
        terminating = true
        t = <value optimized out>
#3  0x00000035332bca56 in __cxxabiv1::__terminate (
    handler=<value optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
No locals.
#4  0x00000035332bca83 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
No locals.
#5  0x00000035332bcb7e in __cxxabiv1::__cxa_throw (obj=0x14d4820, 
    tinfo=<value optimized out>, dest=<value optimized out>)
    at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:83
        header = 0x14d47a0
#6  0x0000000000433c81 in observer::ObserverHandler<pdfobjects::IProperty>::unregisterObserver(boost::shared_ptr<observer::IObserver<pdfobjects::IProperty> const> const&) ()
No symbol table info available.
#7  0x000000000060fc2e in pdfobjects::CContentStream::unregisterCStreamObservers() const ()
Comment 3 Orion Poplawski 2011-05-05 17:18:48 EDT
*** Bug 702453 has been marked as a duplicate of this bug. ***
Comment 4 Orion Poplawski 2011-05-05 17:19:48 EDT
Upstream gui is basically dead.  We are hoping for a qt4 rewrite someday.

Note You need to log in before you can comment on or make changes to this bug.