Bug 605472 - beaker-client cannot be installed due to lack of python-krbV on x86_64.
Summary: beaker-client cannot be installed due to lack of python-krbV on x86_64.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: command line   
(Show other bugs)
Version: 0.5
Hardware: x86_64 Linux
medium
medium vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 03:37 UTC by Igor Zhang
Modified: 2010-06-30 03:09 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 03:09:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Zhang 2010-06-18 03:37:08 UTC
Description of problem:
beaker-client cannot be installed due to lack of python-krbV on x86_64.

Version-Release number of selected component (if applicable):
On RHEL 6 Beta-2, my beaker repo is:
[beaker]
name=Beaker
baseurl=http://beaker-devel.app.eng.bos.redhat.com/harness/RedHatEnterpriseLinux6/$basearch
enabled=1
gpgcheck=0



How reproducible:


Steps to Reproduce:
1.yum install beaker-client -y
2.
3.
  
Actual results:
# yum install beaker-client -y
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package beaker-client.noarch 0:0.5.43-2.el6 set to be updated
--> Processing Dependency: python-setuptools for package: beaker-client-0.5.43-2.el6.noarch
--> Processing Dependency: python-krbV for package: beaker-client-0.5.43-2.el6.noarch
--> Running transaction check
---> Package beaker-client.noarch 0:0.5.43-2.el6 set to be updated
--> Processing Dependency: python-krbV for package: beaker-client-0.5.43-2.el6.noarch
---> Package python-setuptools.noarch 0:0.6.10-1.el6 set to be updated
--> Finished Dependency Resolution
Error: Package: beaker-client-0.5.43-2.el6.noarch (beaker)
           Requires: python-krbV
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@dhcp-65-91 ~]# rpm -qa kobo
kobo-0.2.1-1.el6.noarch
[root@dhcp-65-91 ~]# rpm -qa kobo\*
kobo-client-0.2.1-1.el6.noarch
kobo-0.2.1-1.el6.noarch


Expected results:
Dependancy can be resolved automatically and thus beaker-client can be installed.

Additional info:
I686 doesn't have this problem.

Comment 1 Miroslav Vadkerti 2010-06-28 11:00:52 UTC
Still an issue. Looks like python-krbV was never in distro. Add it to beaker repo for x86_64 please.

Comment 2 Bill Peck 2010-06-29 20:41:37 UTC
This should be fixed now.  Please verify.

Comment 3 Igor Zhang 2010-06-30 02:32:34 UTC
Great. beaker-client can work on x86_64 now.


Note You need to log in before you can comment on or make changes to this bug.