Bug 605528 - MDRaidError: mddeactivate failed for /dev/md0: 09:51:58,247 ERROR : Perhaps a running process, mounted filesystem or active volume group?
Summary: MDRaidError: mddeactivate failed for /dev/md0: 09:51:58,247 ERROR : Perhaps...
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: anaconda_trace_hash:1a69746fc8f7969df...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 07:50 UTC by Ales Kozumplik
Modified: 2014-09-30 23:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 12:39:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (127.50 KB, text/plain)
2010-06-18 07:50 UTC, Ales Kozumplik
no flags Details

Description Ales Kozumplik 2010-06-18 07:50:35 UTC
The following was filed automatically by anaconda:
anaconda 13.21.51 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/mdraid.py", line 211, in mddeactivate
    raise MDRaidError("mddeactivate failed for %s: %s" % (device, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2837, in teardown
    mdraid.mddeactivate(self.path)
  File "/usr/lib/anaconda/storage/__init__.py", line 1296, in findExistingRootDevices
    device.teardown(recursive=True)
  File "/usr/lib/anaconda/upgrade.py", line 94, in findExistingRoots
    rootparts = findExistingRootDevices(anaconda, upgradeany=upgradeany)
  File "/usr/lib/anaconda/upgrade.py", line 81, in findRootParts
    flags.cmdline.has_key("upgradeany"))
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1422, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1335, in nextClicked
    self.setScreen ()
MDRaidError: mddeactivate failed for /dev/md0: 09:51:58,247 ERROR   : Perhaps a running process, mounted filesystem or active volume group?

Comment 1 Ales Kozumplik 2010-06-18 07:50:40 UTC
Created attachment 425030 [details]
Attached traceback automatically from anaconda.

Comment 2 Ales Kozumplik 2010-06-18 07:52:52 UTC
1) installed 0617.0 rhel6 nightly where the root partition is md0 raid over 2 raid partitions, each 3 GB
2) ran 0615.1 rhel6 installer. The crash occurs during 'examining storage devices' step.

Comment 4 RHEL Product and Program Management 2010-06-18 08:13:20 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Chris Lumens 2010-06-18 19:00:40 UTC
Is /mnt/sysimage still mounted when you hit this error message?  I see that it tried to run mount and then immediately after run umount, but there's no errors listed.  Perhaps the unmount failed?

Comment 6 Ales Kozumplik 2010-06-21 12:39:34 UTC
hmm. I am unable to reproduce it today, but I can not think of anything that is different

Let's close this and see if I someone runs into it again.


Note You need to log in before you can comment on or make changes to this bug.