Bug 605547 - oops while doing sysrq-b
oops while doing sysrq-b
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2010-06-18 04:54 EDT by Stefan Assmann
Modified: 2015-09-25 15:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 15:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (1.23 MB, application/octet-stream)
2010-06-18 04:54 EDT, Stefan Assmann
no flags Details

  None (edit)
Description Stefan Assmann 2010-06-18 04:54:09 EDT
Created attachment 425045 [details]
/var/log/messages

Description of problem:
intel-sunriseridge-01.lab.bos.redhat.com

I couldn't login to the system anymore for unknown reasons so I decided to forcefully reboot it with sysrq-b. This caused an oops:

SysRq : Resetting
BUG: scheduling while atomic: swapper/0/0x14010000
Modules linked in: tun(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) uinput(U) igbvf(U) igb(U) i2c_i801(U) iTCO_wdt(U) ioatdma(U) i7core_edac(U) edac_core(U) i2c_core(U) dca(U) iTCO_vendor_support(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) sr_mod(U) cdrom(U) crc_t10dif(U) ahci(U) dm_mod(U) [last unloaded: microcode]
Pid: 0, comm: swapper Not tainted 2.6.32-33.el6.x86_64 #1
Call Trace:
 <NMI>  [<ffffffff81058d16>] __schedule_bug+0x66/0x70
 [<ffffffff814d7bbd>] thread_return+0x205/0x768
 [<ffffffff814db16f>] ? do_nmi+0x22f/0x2d0
 [<ffffffff8106675a>] __cond_resched+0x2a/0x40
 [<ffffffff814db16f>] ? do_nmi+0x22f/0x2d0
 [<ffffffff814d8270>] _cond_resched+0x30/0x40
 [<ffffffff81016006>] is_valid_bugaddr+0x16/0x40
 [<ffffffff8125323f>] report_bug+0x1f/0xc0
 [<ffffffff8101733f>] die+0x7f/0x90
 [<ffffffff814dac94>] do_trap+0xc4/0x160
 [<ffffffff81014ec5>] do_invalid_op+0x95/0xb0
 [<ffffffff814db16f>] ? do_nmi+0x22f/0x2d0
 [<ffffffff81013c8e>] ? apic_timer_interrupt+0xe/0x20
 [<ffffffff81013f5b>] invalid_op+0x1b/0x20
 [<ffffffff814db16f>] ? do_nmi+0x22f/0x2d0
 [<ffffffff814daf64>] ? do_nmi+0x24/0x2d0
 [<ffffffff814da9c0>] nmi+0x20/0x30
 [<ffffffff8102df92>] ? crash_nmi_callback+0x52/0x60
 <<EOE>>
------------[ cut here ]------------
kernel BUG at arch/x86/kernel/traps.c:531!
invalid opcode: 0000 [#1] SMP
last sysfs file: /sys/devices/system/cpu/cpu63/cache/index2/shared_cpu_map
CPU 1
Modules linked in: tun(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) uinput(U) igbvf(U) igb(U) i2c_i801(U) iTCO_wdt(U) ioatdma(U) i7core_edac(U) edac_core(U) i2c_core(U) dca(U) iTCO_vendor_support(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) sr_mod(U) cdrom(U) crc_t10dif(U) ahci(U) dm_mod(U) [last unloaded: microcode]

Modules linked in: tun(U) ip6table_filter(U) ip6_tables(U) ebtable_nat(U) ebtables(U) ipt_MASQUERADE(U) iptable_nat(U) nf_nat(U) bridge(U) stp(U) llc(U) autofs4(U) sunrpc(U) cpufreq_ondemand(U) acpi_cpufreq(U) freq_table(U) be2iscsi(U) bnx2i(U) cnic(U) uio(U) cxgb3i(U) cxgb3(U) mdio(U) ib_iser(U) rdma_cm(U) ib_cm(U) iw_cm(U) ib_sa(U) ib_mad(U) ib_core(U) ib_addr(U) ipv6(U) iscsi_tcp(U) libiscsi_tcp(U) libiscsi(U) scsi_transport_iscsi(U) dm_mirror(U) dm_region_hash(U) dm_log(U) kvm_intel(U) kvm(U) uinput(U) igbvf(U) igb(U) i2c_i801(U) iTCO_wdt(U) ioatdma(U) i7core_edac(U) edac_core(U) i2c_core(U) dca(U) iTCO_vendor_support(U) sg(U) ext4(U) mbcache(U) jbd2(U) sd_mod(U) sr_mod(U) cdrom(U) crc_t10dif(U) ahci(U) dm_mod(U) [last unloaded: microcode]
Pid: 0, comm: swapper Not tainted 2.6.32-33.el6.x86_64 #1 Sunrise Ridge
RIP: 0010:[<ffffffff814db16f>]  [<ffffffff814db16f>] do_nmi+0x22f/0x2d0
RSP: 0018:ffff880483c07f18  EFLAGS: 00010002
RAX: ffff88057b30ffd8 RBX: ffff880483c07f58 RCX: 00000000c0000101
RDX: 00000000ffff8804 RSI: ffffffffffffffff RDI: ffff880483c07f58
RBP: ffff880483c07f48 R08: ffff880483c07e6c R09: ffff880483c07e68
R10: 00003a20caa251a9 R11: 0000000103caa526 R12: ffff880483c07ee8
R13: 00000000fffffffc R14: 0000000000000000 R15: 0000000000000000
FS:  0000000000000000(0000) GS:ffff880483c00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 00000000026f2b18 CR3: 0000000679e49000 CR4: 00000000000006e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process swapper (pid: 0, threadinfo ffff88057b30e000, task ffff880276866af0)
Stack:
 0000000000000000 0000000000000001 ffff880483c07ee8 00000000fffffffc
<0> 0000000000000000 0000000000000000 ffff880483c07e88 ffffffff814da9c0
<0> 0000000000000000 0000000000000000 00000000fffffffc ffff880483c07ee8
Call Trace:
 <NMI>
 [<ffffffff814da9c0>] nmi+0x20/0x30
 [<ffffffff8102df92>] ? crash_nmi_callback+0x52/0x60
 <<EOE>>
Code: ff 31 c0 48 c7 c7 a0 c7 65 81 e8 19 c2 ff ff 83 3d 0a f1 54 00 00 75 26 48 c7 c7 d8 c7 65 81 31 c0 e8 02 c2 ff ff e9 2d fe ff ff <0f> 0b eb fe 0f 0b 66 66 2e 0f 1f 84 00 00 00 00 00 eb f3 48 c7
RIP  [<ffffffff814db16f>] do_nmi+0x22f/0x2d0
 RSP <ffff880483c07f18>

Looks like it's NMI related.

Version-Release number of selected component (if applicable):
kernel-2.6.32-33.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. on the serial console do sysrq-b
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-18 05:13:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Stefan Assmann 2010-06-18 05:28:35 EDT
Tried with nmi_watchdog=0 and no oops occurred.
Comment 7 RHEL Product and Program Management 2010-07-15 10:50:21 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 Don Zickus 2010-07-19 16:19:32 EDT
Stefan,

How are you generating a sysrq-b?  I can't reproduce this with 'echo b > /proc/sysrq-trigger'.  Then again looking at your initial comment, you could not even get to the login prompt, which means you hit some magical 'console/conserver' command in order to generate a sysrq command?

-Don
Comment 9 Stefan Assmann 2010-07-20 02:26:44 EDT
to do sysrq with with console you need to enable sysrq in /etc/sysctl.conf (kernel.sysrq = 1). After that you do:
strg + e consecutively followed by c l 1 b
The last key is whatever sysrq you want to execute
Comment 10 RHEL Product and Program Management 2011-10-07 11:06:25 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.