Bug 605592 - Sound card model isn't updated during conversion
Sound card model isn't updated during conversion
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On: 589567
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 06:49 EDT by Matthew Booth
Modified: 2016-04-26 09:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 589567
Environment:
Last Closed: 2014-11-18 06:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2010-06-18 06:49:46 EDT
+++ This bug was initially created as a clone of Bug #589567 +++

Description of problem:
The guest can not be started up after conversion from Xen.

Version-Release number of selected component (if applicable):
virt-v2v-0.5.2-1.el5
v2v-libvirt-0.8.0.2.el5

How reproducible:
Always

Steps to Reproduce:
# LIBVIRT_DEBUG=1 virsh start rhel5u5-64b-hv-raw-intel
16:59:14.052: debug : virInitialize:343 : register drivers
16:59:14.052: debug : virRegisterDriver:720 : registering Test as driver 0
16:59:14.052: debug : virRegisterNetworkDriver:620 : registering Test as network driver 0
16:59:14.053: debug : virRegisterStorageDriver:651 : registering Test as storage driver 0
16:59:14.053: debug : virRegisterDeviceMonitor:682 : registering Test as device driver 0
16:59:14.053: debug : virRegisterDriver:720 : registering Xen as driver 1
16:59:14.053: debug : virRegisterDriver:720 : registering remote as driver 2
16:59:14.053: debug : virRegisterNetworkDriver:620 : registering remote as network driver 1
16:59:14.053: debug : virRegisterStorageDriver:651 : registering remote as storage driver 1
16:59:14.053: debug : virRegisterDeviceMonitor:682 : registering remote as device driver 1
16:59:14.053: debug : virConnectOpenAuth:1153 : name=(null), auth=0x3c4d69e9a0, flags=0
16:59:14.053: debug : do_open:975 : no name, allowing driver auto-select
16:59:14.053: debug : do_open:983 : trying driver 0 (Test) ...
16:59:14.053: debug : do_open:989 : driver 0 Test returned DECLINED
16:59:14.053: debug : do_open:983 : trying driver 1 (Xen) ...
16:59:14.053: debug : do_open:989 : driver 1 Xen returned DECLINED
16:59:14.053: debug : do_open:983 : trying driver 2 (remote) ...
16:59:14.053: debug : remoteOpen:1006 : Auto-probe remote URI
16:59:14.054: debug : doRemoteOpen:513 : proceeding with name = 
16:59:14.054: debug : call:6555 : Doing call 66 (nil)
16:59:14.054: debug : call:6625 : We have the buck 66 0x2b7de31aa010 0x2b7de31aa010
16:59:14.054: debug : processCallRecvLen:6213 : Got length, now need 36 total (32 more)
16:59:14.054: debug : processCalls:6481 : Giving up the buck 66 0x2b7de31aa010 (nil)
16:59:14.054: debug : call:6656 : All done with our call 66 (nil) 0x2b7de31aa010
16:59:14.054: debug : call:6555 : Doing call 1 (nil)
16:59:14.054: debug : call:6625 : We have the buck 1 0x1a6398a0 0x1a6398a0
16:59:14.054: debug : processCallRecvLen:6213 : Got length, now need 28 total (24 more)
16:59:14.054: debug : processCalls:6481 : Giving up the buck 1 0x1a6398a0 (nil)
16:59:14.054: debug : call:6656 : All done with our call 1 (nil) 0x1a6398a0
16:59:14.054: debug : call:6555 : Doing call 110 (nil)
16:59:14.055: debug : call:6625 : We have the buck 110 0x1a6398a0 0x1a6398a0
16:59:14.055: debug : processCallRecvLen:6213 : Got length, now need 48 total (44 more)
16:59:14.055: debug : processCalls:6481 : Giving up the buck 110 0x1a6398a0 (nil)
16:59:14.055: debug : call:6656 : All done with our call 110 (nil) 0x1a6398a0
16:59:14.055: debug : doRemoteOpen:805 : Auto-probed URI is qemu:///system
16:59:14.055: debug : doRemoteOpen:824 : Adding Handler for remote events
16:59:14.055: debug : doRemoteOpen:831 : virEventAddHandle failed: No addHandleImpl defined. continuing without events.
16:59:14.055: debug : do_open:989 : driver 2 remote returned SUCCESS
16:59:14.055: debug : do_open:1009 : network driver 0 Test returned DECLINED
16:59:14.055: debug : do_open:1009 : network driver 1 remote returned SUCCESS
16:59:14.055: debug : do_open:1031 : storage driver 0 Test returned DECLINED
16:59:14.055: debug : do_open:1031 : storage driver 1 remote returned SUCCESS
16:59:14.055: debug : do_open:1052 : node driver 0 Test returned DECLINED
16:59:14.055: debug : do_open:1052 : node driver 1 remote returned SUCCESS
16:59:14.056: debug : virDomainLookupByName:1771 : conn=0x1a6300a0, name=rhel5u5-64b-hv-raw-intel
16:59:14.056: debug : call:6555 : Doing call 23 (nil)
16:59:14.056: debug : call:6625 : We have the buck 23 0x1a6398a0 0x1a6398a0
16:59:14.056: debug : processCallRecvLen:6213 : Got length, now need 76 total (72 more)
16:59:14.056: debug : processCalls:6481 : Giving up the buck 23 0x1a6398a0 (nil)
16:59:14.056: debug : call:6656 : All done with our call 23 (nil) 0x1a6398a0
16:59:14.056: debug : virGetDomain:271 : New hash entry 0x1a6360d0
16:59:14.056: debug : virDomainGetID:2414 : domain=0x1a6360d0
16:59:14.056: debug : virDomainCreate:3913 : domain=0x1a6360d0
16:59:14.056: debug : call:6555 : Doing call 9 (nil)
16:59:14.056: debug : call:6625 : We have the buck 9 0x1a6398a0 0x1a6398a0
16:59:24.200: debug : processCallRecvLen:6213 : Got length, now need 216 total (212 more)
16:59:24.200: debug : processCalls:6481 : Giving up the buck 9 0x1a6398a0 (nil)
16:59:24.200: debug : call:6656 : All done with our call 9 (nil) 0x1a6398a0
16:59:24.200: debug : virDomainGetName:2321 : domain=0x1a6360d0
error: Failed to start domain rhel5u5-64b-hv-raw-intel
16:59:24.200: debug : virDomainFree:1859 : domain=0x1a6360d0
16:59:24.200: debug : virUnrefDomain:345 : unref domain 0x1a6360d0 rhel5u5-64b-hv-raw-intel 1
16:59:24.200: debug : virReleaseDomain:303 : release domain 0x1a6360d0 rhel5u5-64b-hv-raw-intel
16:59:24.200: debug : virReleaseDomain:315 : unref connection 0x1a6300a0 2
error: internal error Domain rhel5u5-64b-hv-raw-intel didn't show up


16:59:24.200: debug : virConnectClose:1171 : conn=0x1a6300a0
16:59:24.200: debug : call:6555 : Doing call 2 (nil)
16:59:24.200: debug : call:6625 : We have the buck 2 0x1a6398a0 0x1a6398a0
16:59:24.200: debug : processCallRecvLen:6213 : Got length, now need 28 total (24 more)
16:59:24.200: debug : processCalls:6481 : Giving up the buck 2 0x1a6398a0 (nil)
16:59:24.200: debug : call:6656 : All done with our call 2 (nil) 0x1a6398a0
16:59:24.200: debug : virUnrefConnect:210 : unref connection 0x1a6300a0 1
16:59:24.200: debug : virReleaseConnect:171 : release connection 0x1a6300a0
  
Actual results:
The converted guest can't be started.

Expected results:
The converted guest can be started.

Additional info:
Also failed to start the following converted guest.
rhel3u9 i386/x86_64
rhel4u8 i386/x86_64
rhel5u4 i386/x86_64
rhel5u5 i386/x86_64

--- Additional comment from mbooth@redhat.com on 2010-05-06 09:50:16 EDT ---

Neil,

Can you pick just 1 of these failures and attach the complete virt-v2v command line used for conversion and its output.

Thanks,

Matt

--- Additional comment from nzhang@redhat.com on 2010-05-06 10:13:58 EDT ---

Yes, Matt.

# virt-v2v -f /usr/share/doc/virt-v2v-0.5.2/virt-v2v.conf -i libvirtxml -op v2v-test rhel5u5-64b-hv-raw-intel.xml
virt-v2v: The connected hypervisor does not support feature pae
virt-v2v: rhel5u5-64b-hv-raw-intel configured with virtio drivers

# virsh start rhel5u5-64b-hv-raw-intel
error: Failed to start domain rhel5u5-64b-hv-raw-intel
error: internal error Domain rhel5u5-64b-hv-raw-intel didn't show up

--- Additional comment from mbooth@redhat.com on 2010-05-11 10:32:20 EDT ---

Thanks, Neil. Could you please also attach the following:

* /var/log/libvirt/qemu/rhel5u5-64b-hv-raw-intel.log
* output of 'virsh capabilities'

--- Additional comment from nzhang@redhat.com on 2010-05-12 02:50:11 EDT ---

From the guest log, we can see the problem is caused by unknown sound card 'es1370'. But I remember the sound card 'es1370' should be supported by kvm.

# rpm -q kvm
kvm-83-164.el5

# cat /var/log/libvirt/qemu/rhel5u5-64b-hv-raw-intel.log
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin /usr/libexec/qemu-kvm -S -M rhel5.4.0 -m 256 -smp 2 -name rhel5u5-64b-hv-raw-intel -uuid c494a8ae-b1f2-4c9d-96f4-b791c9e9d114 -no-kvm-pit-reinjection -monitor pty -pidfile /var/run/libvirt/qemu//rhel5u5-64b-hv-raw-intel.pid -boot c -drive file=/v2v/rhel5u5-64b-hv-raw-intel.img,if=virtio,index=0,boot=on,format=raw -net nic,macaddr=00:16:36:53:e5:69,vlan=0,model=virtio -net tap,fd=16,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -usbdevice tablet -vnc 127.0.0.1:0 -soundhw es1370 
Unknown sound card name `es1370'
Valid sound card names (comma separated):
ac97        Intel 82801AA AC97 Audio

-soundhw all will enable all of the above

# virsh capabilities
<capabilities>

  <host>
    <cpu>
      <arch>x86_64</arch>
    </cpu>
    <topology>
      <cells num='1'>
        <cell id='0'>
          <cpus num='2'>
            <cpu id='0'/>
            <cpu id='1'/>
          </cpus>
        </cell>
      </cells>
    </topology>
  </host>

  <guest>
    <os_type>hvm</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/libexec/qemu-kvm</emulator>
      <machine>rhel5.4.0</machine>
      <machine>pc</machine>
      <domain type='qemu'>
      </domain>
      <domain type='kvm'>
        <emulator>/usr/libexec/qemu-kvm</emulator>
      </domain>
    </arch>
    <features>
      <pae/>
      <nonpae/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/libexec/qemu-kvm</emulator>
      <machine>rhel5.4.0</machine>
      <machine>pc</machine>
      <domain type='qemu'>
      </domain>
      <domain type='kvm'>
        <emulator>/usr/libexec/qemu-kvm</emulator>
      </domain>
    </arch>
    <features>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

</capabilities>
Comment 2 RHEL Product and Program Management 2010-06-18 07:22:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 RHEL Product and Program Management 2010-07-15 10:30:27 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Matthew Booth 2010-11-29 05:26:42 EST
This bug is dependent on being able to query the target hypervisor to determine what sound card can be added. Guessing wrong results in a guest which won't start. We currently work round it by simply removing the sound card.
Comment 8 RHEL Product and Program Management 2012-05-03 00:38:44 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 9 Richard W.M. Jones 2014-11-18 06:25:21 EST
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs

Note You need to log in before you can comment on or make changes to this bug.