Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605611 - Firefox rendering issues while scrolling when window partially hidden
Firefox rendering issues while scrolling when window partially hidden
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-06-18 07:50 EDT by Vladimir Benes
Modified: 2010-07-15 14:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 14:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scrolling issue (853.53 KB, image/jpeg)
2010-06-21 04:09 EDT, Lubos Kocman
no flags Details
Xorg.0.log (44.22 KB, text/plain)
2010-06-21 12:49 EDT, Vladimir Benes
no flags Details
dmesg (58.01 KB, text/plain)
2010-06-21 12:51 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2010-06-18 07:50:08 EDT
Description of problem:
I see rendering issues while scrolling if the ffox window is moved a bit down from it's original position. The problem can be seen only if the bottom edge is moved below visible area otherwise it behaves well.

Version-Release number of selected component (if applicable):
firefox-3.6.4-7.el6.x86_64

How reproducible:


Steps to Reproduce:
1.grab Firefox window and move it down to hide its bottom edge under visible area
2.scroll up and down
3.
  
Actual results:
rendering issues

Expected results:
seamless rendering

Additional info:
you have to scroll by the touchpad's scroll area (grabbing scroll bar doesn't break things)
Comment 1 RHEL Product and Program Management 2010-06-18 08:03:41 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Matěj Cepl 2010-06-18 17:27:40 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Christopher Aillon 2010-06-19 16:13:32 EDT
And a screenshot please.  "Rendering issue" is rather vague...
Comment 4 Lubos Kocman 2010-06-21 04:09:32 EDT
Created attachment 425562 [details]
scrolling issue

Sorry for bad quality (taken from mobile phone). I wasn't able to use any screenshot tool, as it causes refresh of the screen, and the issue is not so easy to reproduce :-D
Comment 5 Lubos Kocman 2010-06-21 04:10:26 EDT
Hello Issue is not that easy to reproduce, but it's still here (see attached screenshot).


firefox-3.6.4-7.el6.x86_64
xulrunner-1.9.2.4-6.el6.x86_64
Comment 6 Matěj Cepl 2010-06-21 12:31:22 EDT
... and those logs?
Comment 7 Vladimir Benes 2010-06-21 12:49:18 EDT
Created attachment 425690 [details]
Xorg.0.log
Comment 9 Vladimir Benes 2010-06-21 12:51:44 EDT
Created attachment 425691 [details]
dmesg
Comment 15 Lubos Kocman 2010-06-23 05:14:09 EDT
Useful detail:

if you'll click by mouse outside of firefox, these defects will disappear.
Comment 18 Matěj Cepl 2010-06-24 11:47:22 EDT
And yes, I can reproduce this even with other applications ... eclipse for example and scrolling with the list of bugs in Mylyn up and down.
Comment 21 RHEL Product and Program Management 2010-07-15 10:58:55 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 22 Lubos Kocman 2010-07-15 11:03:44 EDT
Hello, this issue seems to be fixed. 

xorg-x11-server-Xorg-1.7.7-20.el6.i686
firefox-3.6.6-2.el6.i686


I think that we may close this as NEXTRELEASE

Lubos
Comment 23 Adam Jackson 2010-07-15 14:39:56 EDT
Closing per comment #22.

Note You need to log in before you can comment on or make changes to this bug.