Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605632 - [RFE] gracefully handle error in allocation memory
[RFE] gracefully handle error in allocation memory
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
1.0
All Linux
medium Severity medium
: 2.2
: ---
Assigned To: Matthew Farrellee
MRG Quality Engineering
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 08:44 EDT by Martin Kudlej
Modified: 2012-06-23 07:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 15:22:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2010-06-18 08:44:18 EDT
Description of problem: 
Scheduler can crash during submitting because it cannot allocate more memory than 3GB on PAE kernel. I think that it will be good if it will not crash but it will log error to logs and gracefully close submit transaction and clean after unsuccessful submission.
Please see crash examples in these BZs #603658 #603657.

Version-Release number of selected component (if applicable):
condor-7.4.3-0.17.el5

Please feel free to reassign this bug to another milestone.
Comment 1 Matthew Farrellee 2012-06-22 15:22:08 EDT
Please use a 64bit condor_schedd.

Note You need to log in before you can comment on or make changes to this bug.