Bug 605666 - [abrt] crash in pulseaudio-equalizer-2.7-1.fc13: pulseaudio-equalizer.py:46:GetSettings:IOError: [Errno 2] No such file or directory: '/root/.pulse/equalizerrc'
Summary: [abrt] crash in pulseaudio-equalizer-2.7-1.fc13: pulseaudio-equalizer.py:46:G...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio-equalizer   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hicham HAOUARI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:16bcf319
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 14:10 UTC by Kiran
Modified: 2010-08-11 13:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 13:28:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (586 bytes, text/plain)
2010-06-18 14:10 UTC, Kiran
no flags Details

Description Kiran 2010-06-18 14:10:37 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: python /usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py
component: pulseaudio-equalizer
executable: /usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py
kernel: 2.6.33.3-85.fc13.x86_64
package: pulseaudio-equalizer-2.7-1.fc13
reason: pulseaudio-equalizer.py:46:GetSettings:IOError: [Errno 2] No such file or directory: '/root/.pulse/equalizerrc'
release: Fedora release 13 (Goddard)

backtrace
-----
pulseaudio-equalizer.py:46:GetSettings:IOError: [Errno 2] No such file or directory: '/root/.pulse/equalizerrc'

Traceback (most recent call last):
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 519, in <module>
    Equalizer()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 354, in __init__
    GetSettings()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 46, in GetSettings
    f = open(eqconfig, "r")
IOError: [Errno 2] No such file or directory: '/root/.pulse/equalizerrc'

Local variables in innermost frame:

Comment 1 Kiran 2010-06-18 14:10:40 UTC
Created attachment 425131 [details]
File: backtrace

Comment 2 Hicham HAOUARI 2010-06-18 16:05:16 UTC
how did you manage to launch it as root ?

Comment 3 mkronsteiner 2010-08-11 12:55:59 UTC
Package: pulseaudio-equalizer-2.7-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Start PulseAudio Equalizer from Gnome Menu
2.
3.


Comment
-----
Just wanted to start it...

Comment 4 Hicham HAOUARI 2010-08-11 13:13:20 UTC
what do you get if you type this in a terminal :

python -c "import os; print os.getenv('HOME');"

Comment 5 mkronsteiner 2010-08-11 13:23:26 UTC
[root@localhost ~]# python -c "import os; print os.getenv('HOME');"
/root

Comment 6 Hicham HAOUARI 2010-08-11 13:28:39 UTC
As I said, this program isn't intended to be run as root. So you are on your own on this.


Note You need to log in before you can comment on or make changes to this bug.