Bug 605677 - qt-webkit based browsers crashes with flash-plugin 10.1.53.64
qt-webkit based browsers crashes with flash-plugin 10.1.53.64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 604284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 10:34 EDT by nucleo
Modified: 2010-07-13 03:43 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt-4.6.3-8.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 03:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 241702 None None None Never
WebKit Project 40567 None None None Never

  None (edit)
Description nucleo 2010-06-18 10:34:03 EDT
Description of problem:
arora and konqueror with webkitpart are crashes after updating of flash-plugin to 10.1.53.64 

Version-Release number of selected component (if applicable):
qt-4.6.2-20.fc13

How reproducible:
Every time.

Steps to Reproduce:
1. Install flash-plugin 10.1.53.64.
2. Open adobe.com in arora or in konqueror and switch to WebKit engine.
  
Actual results:
crash

Additional info:
See bug https://bugs.webkit.org/show_bug.cgi?id=40567
and fix for this bug http://trac.webkit.org/changeset/61307
Comment 1 nucleo 2010-06-18 10:41:18 EDT
See this backtrace for arora crash https://bug-40567-attachments.webkit.org/attachment.cgi?id=58678

I am on i686, nspluginwrapper not installed.
Comment 2 Rex Dieter 2010-06-18 11:14:14 EDT
* Fri Jun 18 2010 Rex Dieter <rdieter@fedoraproject.org> 4.7.0-0.19.beta1
- revert -no-javascript-jit change, false-alarm (#604003)
- QtWebKit does not search correct plugin path(s) (#568860)
- QtWebKit browsers crash with flash-plugin (rh#605677,webkit#40567)
- drop qt-x11-opensource-src-4.5.0-gcc_hack.patch
Comment 3 Rex Dieter 2010-06-18 11:51:00 EDT
* Fri Jun 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.3-4
- QtWebKit does not search correct plugin path(s) (#568860)
- QtWebKit browsers crash with flash-plugin (rh#605677,webkit#40567)
Comment 4 Kalev Lember 2010-06-19 17:04:44 EDT
*** Bug 604284 has been marked as a duplicate of this bug. ***
Comment 5 Viktor Erdelyi 2010-06-20 15:48:52 EDT
I tested qt-4.6.3-4.fc13.i686* (and its dependencies) from koji and it fixed the problem for me. No noticeable regressions so far.

* http://koji.fedoraproject.org/koji/buildinfo?buildID=178642
Comment 6 Fedora Update System 2010-07-12 08:54:26 EDT
qt-4.6.3-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/qt-4.6.3-8.fc13
Comment 7 Fedora Update System 2010-07-12 08:56:29 EDT
qt-4.6.3-8.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/qt-4.6.3-8.fc12
Comment 8 Fedora Update System 2010-07-13 03:39:20 EDT
qt-4.6.3-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-07-13 03:42:55 EDT
qt-4.6.3-8.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.