Bug 605732 - service kdump start fails even though there is memory reserved for the crashkernel
service kdump start fails even though there is memory reserved for the crashk...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
CAI Qian
:
: 608476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 12:10 EDT by Jeff Moyer
Modified: 2010-11-10 16:00 EST (History)
2 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-122
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:00:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correctly limit kernel text size (649 bytes, patch)
2010-07-15 12:41 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Jeff Moyer 2010-06-18 12:10:25 EDT
Description of problem:
On one of my systems, service kdump start fails, with no reason given.  /var/log/messages just shows that the kexec kernel failed to load:

Jun 18 12:04:02 metallica kdump: kexec: failed to load kdump kernel
Jun 18 12:04:02 metallica kdump: failed to start up

The crashkernel has memory reserved:

[root@metallica ~]# cat /proc/iomem 
00000000-00000fff : reserved
00001000-0009fbff : System RAM
0009fc00-0009ffff : reserved
000f0000-000fffff : reserved
00100000-d7e65fff : System RAM
  01000000-0150faf4 : Kernel code
  0150faf5-0192122f : Kernel data
  01c28000-028c3717 : Kernel bss
  04000000-0bffffff : Crash kernel

[root@metallica ~]# cat /proc/cmdline
ro root=UUID=fcd9cac9-0500-4c87-b1e0-f992ee94c289 console=ttyS1 crashkernel=128M@64M elevator=deadline SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us


Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-77
kernel-2.6.32-36.el6.x86_64.debug

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-06-18 12:23:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Neil Horman 2010-06-18 15:05:57 EDT
I"ve spoken and tested with jeff on this, and this appears limited to the debug kernels.  I think whats happening is that the debug kernels have a different START_KERNEL vaddr than the non-debug kernels, and kdump doesn't know about that, so it fails in get_kernel_vaddr_and_size.  I'll investigate and put a patch together soon.
Comment 4 Neil Horman 2010-06-28 09:57:37 EDT
*** Bug 608476 has been marked as a duplicate of this bug. ***
Comment 5 RHEL Product and Program Management 2010-07-15 10:26:50 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Neil Horman 2010-07-15 12:39:53 EDT
Jeff, I think I was close, but not quite spot on with my assumption in comment 3.  Its not the kernel start address that we're failing to find, but the comparison on its end address.  The kernel can be up to 512Mb in size, but kexec thinks it can only be 40Mb.  I'm guessing that the debug kernel fails the KERNEL_TEXT_SIZE check.  I've updated it the patch I'm going to attach shortly.  If you could try this build:
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2602294
Which has the patch attached and confirm it solves the problem here, that would be great.  Thanks!
Comment 7 Neil Horman 2010-07-15 12:41:00 EDT
Created attachment 432139 [details]
patch to correctly limit kernel text size
Comment 8 CAI Qian 2010-07-16 12:35:12 EDT
This is working for me.
Comment 9 Jeff Moyer 2010-07-21 12:04:06 EDT
This works for me.  Thanks!
Comment 11 releng-rhel@redhat.com 2010-11-10 16:00:20 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.