Bug 60578 - up2date -u gives xmlrpclib.ResponseError
up2date -u gives xmlrpclib.ResponseError
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 14:45 EST by David M. Cook
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 19:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David M. Cook 2002-03-01 14:45:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.up2date -u
2.
3.
	

Actual Results:  [jchotz@vmlinux jchotz]$ up2date -u
Password:

Retrieving list of all available packages...
########################################
Traceback (innermost last):
  File "/usr/sbin/up2date", line 1014, in ?
    main()
  File "/usr/sbin/up2date", line 341, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 900, in batchRun
    printCallback, percentCallback)
  File "/usr/sbin/up2date", line 820, in runInteractive
    progressCallback = percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1534, in
+getUpdatedPackageList
    pkgList = getAvailablePackageList(msgCallback,progressCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 692, in
+getAvailablePackageList
    tmp_args,tmp_method = xmlrpclib.loads(blip)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 535, in loads
    return u.close(), u.getmethodname()
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 364, in close
    raise ResponseError()
xmlrpclib.ResponseError: <xmlrpclib.ResponseError instance at 81ded00>


Expected Results:  updates applied or an error message

Additional info:

redhat-release-7.1-1
up2date-2.7.11-7.x.1
Comment 1 Adrian Likins 2002-03-01 16:13:34 EST
should be fixed in cvs now, and should be fixed in the
next version of the client.

What happened is it looks like you had a corrupt package list
cache file. This probabaly happened because of a network
error. The next version of the client will detect this and
fetch a new version of the list in that case.
Comment 2 David M. Cook 2002-03-08 19:33:20 EST
Verified by "corrupting" the package cache in /var/spool/up2date by removing the
last 20k or so of the file with dd.

Note You need to log in before you can comment on or make changes to this bug.