Bug 605882 - "yum install openldap-servers" pulls in i686 packages on x86_64
"yum install openldap-servers" pulls in i686 packages on x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-19 00:35 EDT by Braden McDaniel
Modified: 2014-01-21 18:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-19 01:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2010-06-19 00:35:10 EDT
Description of problem:

# yum install openldap-servers
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Adding en_US to language list
Found 131 installed debuginfo package(s)
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openldap-servers.x86_64 0:2.4.21-4.fc13 set to be updated
--> Processing Dependency: openldap = 2.4.21-4.fc13 for package: openldap-servers-2.4.21-4.fc13.x86_64
--> Running transaction check
---> Package openldap.i686 0:2.4.21-4.fc13 set to be updated
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libsasl2.so.2 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.2) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libssl.so.10 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libcrypto.so.10 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libresolv.so.2(GLIBC_2.2) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.12) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libresolv.so.2 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libpthread.so.0 for package: openldap-2.4.21-4.fc13.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: openldap-2.4.21-4.fc13.i686
--> Running transaction check
---> Package cyrus-sasl-lib.i686 0:2.1.23-11.fc13 set to be updated
--> Processing Dependency: libdb-4.8.so for package: cyrus-sasl-lib-2.1.23-11.fc13.i686
---> Package glibc.i686 0:2.12-2 set to be updated
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-2.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-2.i686
---> Package openssl.i686 0:1.0.0a-1.fc13 set to be updated
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libz.so.1 for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.0a-1.fc13.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.0a-1.fc13.i686
--> Running transaction check
---> Package db4.i686 0:4.8.30-1.fc13 set to be updated
---> Package krb5-libs.i686 0:1.7.1-10.fc13 set to be updated
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.7.1-10.fc13.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.7.1-10.fc13.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.7.1-10.fc13.i686
---> Package libcom_err.i686 0:1.41.10-6.fc13 set to be updated
---> Package nss-softokn-freebl.i686 0:3.12.4-19.fc13 set to be updated
---> Package zlib.i686 0:1.2.3-23.fc12 set to be updated
--> Running transaction check
---> Package keyutils-libs.i686 0:1.2-6.fc12 set to be updated
---> Package libselinux.i686 0:2.0.90-5.fc13 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch         Version              Repository     Size
================================================================================
Installing:
 openldap-servers         x86_64       2.4.21-4.fc13        fedora        2.6 M
Installing for dependencies:
 cyrus-sasl-lib           i686         2.1.23-11.fc13       fedora        135 k
 db4                      i686         4.8.30-1.fc13        updates       614 k
 glibc                    i686         2.12-2               updates       4.3 M
 keyutils-libs            i686         1.2-6.fc12           fedora         18 k
 krb5-libs                i686         1.7.1-10.fc13        updates       656 k
 libcom_err               i686         1.41.10-6.fc13       fedora         34 k
 libselinux               i686         2.0.90-5.fc13        fedora        104 k
 nss-softokn-freebl       i686         3.12.4-19.fc13       updates       111 k
 openldap                 i686         2.4.21-4.fc13        fedora        232 k
 openssl                  i686         1.0.0a-1.fc13        updates       1.4 M
 zlib                     i686         1.2.3-23.fc12        fedora         69 k

Transaction Summary
================================================================================
Install      12 Package(s)
Upgrade       0 Package(s)

Total download size: 10 M
Installed size: 27 M
Is this ok [y/N]: 


Version-Release number of selected component (if applicable):
3.2.27-4.fc13

Additional info:
Also note:

# rpm -q openldap
openldap-2.4.21-6.fc13.x86_64

This may be another case that https://fedoraproject.org/wiki/PackagingDrafts/ArchSpecificRequires is needed to address. Filing this in case it's an actual yum bug.
Comment 1 James Antill 2010-06-19 01:09:23 EDT
--> Processing Dependency: openldap = 2.4.21-4.fc13 for package:
[...]
# rpm -q openldap
openldap-2.4.21-6.fc13.x86_64

...the problem is that 2.4.21-6 != 2.4.21-4 (I assume you've got a newer openldap from updates-testing). Yum won't downgrade, so it's choices are: 1) abort/fail. 2) Install the .i686 package of the correct version.

 Arch specific requires will remove option #2, which is almost certainly the correct thing here. Or just enabling updates-testing (assuming that's where it's from), for the install, will dtrt.
Comment 2 Braden McDaniel 2010-06-19 02:37:15 EDT
(In reply to comment #1)
> --> Processing Dependency: openldap = 2.4.21-4.fc13 for package:
> [...]
> # rpm -q openldap
> openldap-2.4.21-6.fc13.x86_64
> 
> ...the problem is that 2.4.21-6 != 2.4.21-4 (I assume you've got a newer
> openldap from updates-testing). Yum won't downgrade, so it's choices are: 1)
> abort/fail. 2) Install the .i686 package of the correct version.

I looked right past that. But I have not been using updates-testing; so I don't think that's what happened here.

>  Arch specific requires will remove option #2, which is almost certainly the
> correct thing here. Or just enabling updates-testing (assuming that's where
> it's from), for the install, will dtrt.    

Since I haven't been using updates-testing, perhaps something has gone sideways with the repos?

Note You need to log in before you can comment on or make changes to this bug.