Bug 605917 - SELinux is preventing /usr/libexec/gdm-simple-greeter "read" access on john.
SELinux is preventing /usr/libexec/gdm-simple-greeter "read" access on j...
Status: CLOSED DUPLICATE of bug 605919
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f34be1e9d7e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-19 08:14 EDT by John Margaritopoulos
Modified: 2010-07-07 11:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 06:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Margaritopoulos 2010-06-19 08:14:12 EDT
Summary:

SELinux is preventing /usr/libexec/gdm-simple-greeter "read" access on john.

Detailed Description:

SELinux denied access requested by gdm-simple-gree. It is not expected that this
access is required by gdm-simple-gree and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:default_t:s0
Target Objects                john [ dir ]
Source                        gdm-simple-gree
Source Path                   /usr/libexec/gdm-simple-greeter
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.29.92-6.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.15-4.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux fedora.localdomain 2.6.33.1-24.fc13.i686 #1
                              SMP Tue Mar 30 18:49:12 UTC 2010 i686 i686
Alert Count                   10
First Seen                    Fri 23 Apr 2010 09:44:26 PM EEST
Last Seen                     Fri 23 Apr 2010 09:45:02 PM EEST
Local ID                      ebe96b6e-7e60-4638-b080-2349cb009de7
Line Numbers                  

Raw Audit Messages            

node=fedora.localdomain type=AVC msg=audit(1272048302.59:25): avc:  denied  { read } for  pid=1705 comm="gdm-simple-gree" name="john" dev=sda3 ino=14213121 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=dir

node=fedora.localdomain type=SYSCALL msg=audit(1272048302.59:25): arch=40000003 syscall=292 success=no exit=-13 a0=b a1=90f2220 a2=1002fce a3=90f1488 items=0 ppid=1671 pid=1705 auid=4294967295 uid=42 gid=478 euid=42 suid=42 fsuid=42 egid=478 sgid=478 fsgid=478 tty=(none) ses=4294967295 comm="gdm-simple-gree" exe="/usr/libexec/gdm-simple-greeter" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-simple-gree,xdm_t,default_t,dir,read
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t default_t:dir read;
Comment 1 Miroslav Grepl 2010-06-21 06:46:26 EDT

*** This bug has been marked as a duplicate of bug 605919 ***

Note You need to log in before you can comment on or make changes to this bug.