Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 605929 - SELinux is preventing /usr/libexec/gdm-session-worker "create" access on .xsession-errors.
SELinux is preventing /usr/libexec/gdm-session-worker "create" access on...
Status: CLOSED DUPLICATE of bug 605919
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:2ad63988c9b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-19 08:44 EDT by John Margaritopoulos
Modified: 2010-07-07 11:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 06:48:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Margaritopoulos 2010-06-19 08:44:22 EDT
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "create" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:default_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.30.2-1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686 #1
                              SMP Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   198
First Seen                    Sun 25 Apr 2010 06:21:18 PM EEST
Last Seen                     Sat 19 Jun 2010 01:24:58 PM EEST
Local ID                      95bcf96b-1b12-4514-9edb-c0cce5767edd
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276943098.230:24): avc:  denied  { create } for  pid=6219 comm="gdm-session-wor" name=".xsession-errors" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1276943098.230:24): avc:  denied  { read append open } for  pid=6219 comm="gdm-session-wor" name=".xsession-errors" dev=sda3 ino=14214071 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1276943098.230:24): arch=40000003 syscall=5 success=yes exit=12 a0=9ff71c0 a1=442 a2=180 a3=9ff71c0 items=0 ppid=3364 pid=6219 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,default_t,file,create
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t default_t:file { read create open append };
Comment 1 Miroslav Grepl 2010-06-21 06:48:56 EDT

*** This bug has been marked as a duplicate of bug 605919 ***

Note You need to log in before you can comment on or make changes to this bug.