Bug 606018 - Radeon Driver Crashes On Screens With Certain EDID Information
Radeon Driver Crashes On Screens With Certain EDID Information
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Dave Airlie
Red Hat Kernel QE team
:
Depends On:
Blocks: 767187 846704
  Show dependency treegraph
 
Reported: 2010-06-19 20:19 EDT by Gordan Bobic
Modified: 2017-12-06 07:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EDID - works for POST, Windows, and RHEL6b (553 bytes, text/plain)
2010-06-19 20:19 EDT, Gordan Bobic
no flags Details
EDID - works for POST and Windows, but RHEL6b dies as soon as Radeon kernel module loads (553 bytes, text/plain)
2010-06-19 20:21 EDT, Gordan Bobic
no flags Details

  None (edit)
Description Gordan Bobic 2010-06-19 20:19:23 EDT
Created attachment 425401 [details]
EDID - works for POST, Windows, and RHEL6b

Description of problem:

Radeon kernel level driver will crash or render the screen permanently black and unusable if it encounters certain EDID information.

How reproducible:

Every time.

Steps to Reproduce:
1. Flash monitor EDID to one known to cause a problem
2. Boot RHEL6b with in a setup that boots into high-res text mode
3. As soon as the kernel goes into high-res mode, the machine will either crash, or at best the screen will go permanently blank.

Additional info:

This result has been produced on an IBM/Lenovo ThinkPad T60 with a 2048x1536 (QXGA) TFT panel upgrade (IDTech IAQX10N), and ATI Radeon X1400 GPU. I haven't quite managed to pin the problem down to the exact byte of the EDID configuration that causes a problem, but I have narrowed it down almost to that point. To the best of my ability to tell, it is related to either:

1) V/H sync polarity (I doubt this is the problem)
2) Vertical sync timings (more likely):
1536 Active, 5 Blank, 1 Offset, 3 Width - doesn't work
1536 Active, 16 Blank, 8 Offset, 8 Width - works

Purely guessing, but it could be the radeon driver applying some rounding to the EDID figures to get them to a multiple of something, and rounding them in the wrong direction.

Attaches are two EDID spec files:
1) post-win-lin-IDT22CE.dat
This EDID works fine for POST, for Windows, and for RHEL6b high-res text mode and Xorg.

2) post-win-IDT22CE.dat
This EDID works fine for POST and for Windows, but under RHEL6b, the kernel will either crash or permanently cause the screen to go black.

You can use something like the Phoenix EDID editor to show the content in a more human-readable form. The only difference between the two EDIDs attached are in the Descriptor Block #1.

Fedora 12 does not seem to suffer from this bug.
Comment 1 Gordan Bobic 2010-06-19 20:21:02 EDT
Created attachment 425402 [details]
EDID - works for POST and Windows, but RHEL6b dies as soon as Radeon kernel module loads
Comment 3 RHEL Product and Program Management 2010-06-19 20:32:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 RHEL Product and Program Management 2010-07-15 10:36:39 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 Jérôme Glisse 2011-11-07 14:02:02 EST
Gordan still an issue with 6.2 ?
Comment 7 Gordan Bobic 2011-11-07 15:16:41 EST
I don't know - have you reproduced and tested it with the attached EDID data?
Comment 9 RHEL Product and Program Management 2012-05-03 00:39:38 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 10 Jan Kurik 2017-12-06 07:20:49 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.