Bug 606142 - [X1400] random crashes hang the system
[X1400] random crashes hang the system
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
All Linux
low Severity high
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 17:19 EDT by Pablo Rodríguez
Modified: 2018-04-11 04:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-09 00:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages w/nomodeset (517.85 KB, text/plain)
2010-06-30 17:47 EDT, Pablo Rodríguez
no flags Details
/var/log/Xorg.0.log w/nomodeset (52.91 KB, text/plain)
2010-06-30 17:48 EDT, Pablo Rodríguez
no flags Details
dmesg output w/nomodeset (34.57 KB, text/plain)
2010-06-30 17:49 EDT, Pablo Rodríguez
no flags Details
standard dmesg output (36.56 KB, text/plain)
2010-06-30 17:59 EDT, Pablo Rodríguez
no flags Details
standard /var/log/Xorg.0.log (78.74 KB, text/plain)
2010-06-30 18:00 EDT, Pablo Rodríguez
no flags Details
standard /var/log/messages (589.65 KB, text/plain)
2010-06-30 18:03 EDT, Pablo Rodríguez
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 28402 None None None Never
FreeDesktop.org 28821 None None None Never

  None (edit)
Description Pablo Rodríguez 2010-06-20 17:19:31 EDT
I have an X1400 ATI graphics card that I have been using withouth any problem with both Mandriva and openSUSE and the radeonhd driver.

Since I switched to Ubuntu 10.04 and now to Fedora 13, I experience a weird bug: when the X server loads the video driver (at the very beginning of the system loading), some times it crashes and all that can be seen is a blank screen with some red points on the top.

The system is totally unresponsive and all I can do is turn the computer off and restart again. It doesn't happen always, but almost every other time I restart or turn on the laptop.

I don't know which files do you need to check the issue.

If you were so kind to tell me how to do it, I don't even mind to report the bug upstream.

Just in case it helps, I reported the bug in Ubuntu (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/584525) and here you have the lspci output:

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility X1400 [1002:7145] (prog-if 00 [VGA controller])
	Subsystem: Dell Device [1028:2003]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 27
	Region 0: Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Region 1: I/O ports at ee00 [size=256]
	Region 2: Memory at efdf0000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at efd00000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: radeon
	Kernel modules: radeon

Thanks for your help,


Pablo
Comment 1 Pablo Rodríguez 2010-06-20 17:23:12 EDT
Just in case it helps, driver seems to be xorg-x11-drv-ati-6.13.0-1.fc13.i686.
Comment 2 Pablo Rodríguez 2010-06-29 10:24:37 EDT
After upgrading yesterday some X packages via "yum update" when I start the computer next time, I realize that it crashes every time I start the OS.

So my laptop is totally unusable. I'm going to report this upstream, but I'd need to know how to disable the loading of X server at the start.

The system is totally unusable, so priority should be definitively higher than low.

Thanks for your help,


Pablo
Comment 3 Pablo Rodríguez 2010-06-29 10:34:06 EDT
At least it would be extremely helpful to use the computer in the meantime (I really need to), if you were so kind to explain me how to switch to the radeonhd driver.
Comment 4 Dave Airlie 2010-06-30 01:53:51 EDT
does booting with nomodeset help?
Comment 5 Pablo Rodríguez 2010-06-30 14:52:50 EDT
Adding the radeon.modeset=0 to the kernel command line seems to work, but I don't know whether crashes are random again.
Comment 6 Matěj Cepl 2010-06-30 16:39:21 EDT
(In reply to comment #5)
> Adding the radeon.modeset=0 to the kernel command line seems to work, but I
> don't know whether crashes are random again.    

Setting this bug to needinfo and let us know if it happens again even with nomodeset. Meanwhile, could we get (from running both with and without nomodeset; you can collect the logs even from text mode after Xorg crashes) following logs attached to this bug as separate uncompressed attachments:

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 Pablo Rodríguez 2010-06-30 17:05:31 EDT
(In reply to comment #6)
> Setting this bug to needinfo and let us know if it happens again even with
> nomodeset. Meanwhile, could we get (from running both with and without
> nomodeset; you can collect the logs even from text mode after Xorg crashes)
> following logs attached to this bug as separate uncompressed attachments:

I'm afraid I haven't expressed myself accurately. The X server crashes when loading the radeon driver, but I'm afraid I'm not able to get to the text mode (unless you have a way to do it). The computer seems to be frozen.

> * your X server config file (/etc/X11/xorg.conf, if available),

I'm afraid it is not available.

> * X server log file (/var/log/Xorg.*.log)
> * output of the dmesg command, and
> * system log (/var/log/messages)

I guess I can do this as normal user after booting the system. Are there any special requirements I should meet?

Thanks for your help,


Pablo
Comment 8 Pablo Rodríguez 2010-06-30 17:47:18 EDT
Created attachment 428111 [details]
/var/log/messages w/nomodeset
Comment 9 Pablo Rodríguez 2010-06-30 17:48:30 EDT
Created attachment 428114 [details]
/var/log/Xorg.0.log w/nomodeset
Comment 10 Pablo Rodríguez 2010-06-30 17:49:24 EDT
Created attachment 428118 [details]
dmesg output w/nomodeset
Comment 11 Pablo Rodríguez 2010-06-30 17:59:48 EDT
Created attachment 428124 [details]
standard dmesg output
Comment 12 Pablo Rodríguez 2010-06-30 18:00:42 EDT
Created attachment 428125 [details]
standard /var/log/Xorg.0.log
Comment 13 Pablo Rodríguez 2010-06-30 18:03:19 EDT
Created attachment 428127 [details]
standard /var/log/messages

I'm afraid that crashes are random again, since I removed the radeon.modeset=0 from the grub command line and I have been able to start the X server.
Comment 14 Pablo Rodríguez 2010-11-30 10:17:32 EST
I'm not sure whether this will work, but Alex Deucher suggest a patch for radeon drm (http://bugs.freedesktop.org/show_bug.cgi?id=28821#c4).

Would it be possible to apply it?

Thanks for your help,


Pablo
Comment 15 Pablo Rodríguez 2010-11-30 11:27:32 EST
Reading https://bugs.freedesktop.org/show_bug.cgi?id=28402, the patch proposed in my previous comment seem to fix the hangs.

Considering that these are system freezes, could you release a patched version soon?

Thanks for your help,
Comment 16 Pablo Rodríguez 2010-12-01 11:31:21 EST
Thanks for the review of this report, Matej.

I forgot to tell that this bugs happens with Fedora 14.

BTW, I don't understand why severity was lowered from “urgent” to “high” (although these would be better labels for priority). The system hangs render the laptop totally unusable and all non-saved work is lost.

Thanks for your help,


Pablo
Comment 17 Pablo Rodríguez 2010-12-01 14:49:15 EST
This is the third time I experience the system hang in less than four hours use (I don't use my laptop before 16:00).

First, I was using Mozilla, opening a new tab with Ctrl+click. Second, it was mplayer watching a movie. Third was Evolution checking for new messages (which could mess all my mail folders).

Hangs are random not because they are infrequent, but because I cannot explain the cause. And just in case I haven't explained myself clearly, I have to shut down the laptop by cutting the electrical supply (this cannot be good for the computer).

I'm an average user and applying the patch and compiling the kernel myself isn't an easy task for me.

The patch is so simple and specific that it should be harmless.

Sorry for insisting, but three system freezes (and consequential data loss) in less than four hours is too much (at least for me).

Thanks for your help,


Pablo
Comment 18 Dave Airlie 2010-12-02 20:27:09 EST
I'm not sure this patch is needed on the F14 2.6.35.x kernel, the regression only occured in 2.6.36 from what I can see here.
Comment 19 Pablo Rodríguez 2010-12-03 10:31:08 EST
(In reply to comment #18)
> I'm not sure this patch is needed on the F14 2.6.35.x kernel, the regression
> only occured in 2.6.36 from what I can see here.

Thanks for your reply, Dave.

I don't understand your comment, since you added the patch at http://koji.fedoraproject.org/koji/buildinfo?buildID=204223 (among other ones).

I have installed it and I'm experiencing no hangs, but I haven't used the laptop too much. I'll report later if the hangs dissapeared.

Thanks again,


Pablo
Comment 20 Pablo Rodríguez 2010-12-08 07:18:59 EST
As already reported in http://bugs.freedesktop.org/show_bug.cgi?id=28821#c9, I'm not experiencing system hangs, so I think that this bug can be closed.

Just in case I experience a hang again, I'll reopen the bug.

Thanks for your help,

Pablo

Note You need to log in before you can comment on or make changes to this bug.