Bug 60620 - emulate3buttons broken in XFree86 4.1.0-15 rpm
emulate3buttons broken in XFree86 4.1.0-15 rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-02 14:45 EST by Mike Potts
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-02 14:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Potts 2002-03-02 14:45:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/20020205

Description of problem:
After upgrading from XFree86 v. 4.0.3 to 4.1.0-15 via up2date
I could no longer emulate a 3-button mouse on my Sony VAIO PCG_XG19
laptop.  I found some references to this online but no solutions
other than a mention of a similar bug being fixed in the next update
to XFree86 4.2.0 (4.2.1? 4.3.0?).  The config file is
/etc/X11/XF86Config-4 and the option is:

  "Emulate3Buttons" "on"

Reverting to XFree86 4.0.3 again (from ftp.redhat.com RPM) has
fixed the problem for me but I'm seeing weird font issues now so
I'm clearly out of sync beyond what RPM dependencies can control.

Version-Release number of selected component (if applicable):
4.1.0-15

How reproducible:
Always

Steps to Reproduce:
1. Run X on my laptop with Emulate3Buttons set in XF86Config-4
2. Try to produce 'middle' button click

	

Actual Results:  Nothing.


Expected Results:  Middle-button action.


Additional info:

Excerpt from config:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/mouse"
        Option      "Protocol" "GlidePointPS/2"
        Option      "Emulate3Buttons" "on"
        Option      "ZAxisMapping" "4 5"
EndSection
Comment 1 Mike A. Harris 2002-03-12 02:26:21 EST
I am unable to reproduce this problem on any of my machines, so I am
assuming it is either a local configuration issue, or it is fixed in
rawhide now.

As for dependancy issues you may have had, if you'vre used
rpm --nodeps and/or --force, then rpm dependancy checking is not
in control anyway, and you will have all sorts of random problems.

Note You need to log in before you can comment on or make changes to this bug.