Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606208 - gpk-application not able to install package collections
gpk-application not able to install package collections
Status: CLOSED DUPLICATE of bug 589119
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 02:07 EDT by Pablo Rodríguez
Modified: 2010-10-19 14:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 14:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Rodríguez 2010-06-21 02:07:50 EDT
gnome-packagekit-2.30.2-1.fc13 is not able to install any package collection.

Select the package, apply selection, gpk-application starts and seems to run, but after a second it stops, the package is selected to be aplied again.

Is there any way to do this through the CLI?

Thanks for your help,


Pablo
Comment 1 mike 2010-08-31 22:16:52 EDT
(In reply to comment #0)
> gnome-packagekit-2.30.2-1.fc13 is not able to install any package collection.
> 
> Select the package, apply selection, gpk-application starts and seems to run,
> but after a second it stops, the package is selected to be aplied again.
> 
> Is there any way to do this through the CLI?
> 
> Thanks for your help,
> 
> 
> Pablo


I had the same problem on one hardware platform with F13 trying to use the System Administration Add/Remove Software function, the same install worked fine on a different platform.  Reinstalling didn't help. This workaround worked for me:

[root@LIN2 Mikey]# yum remove PackageKit gnome-packagekit
Loaded plugins: presto, refresh-packagekit
...
Complete!
[root@LIN2 Mikey]# yum install PackageKit gnome-packagekit
Loaded plugins: presto
Setting up Install Process
Resolving Dependencies
....
Complete!

Add/Remove now works correctly.
Comment 2 Ira Malinich 2010-09-14 15:57:33 EDT
I'm seeing the same behaviour in F14 (late in the F14 Alpha timeframe).  I've got gnome-packagekit-2.31.91-2.fc14.x86_64 installed.  I haven't tried uninstalling and re-installing PackageKit yet.
Comment 3 Ira Malinich 2010-09-14 15:59:57 EDT
(In reply to comment #2)
> I'm seeing the same behaviour in F14 (late in the F14 Alpha timeframe).  I've
> got gnome-packagekit-2.31.91-2.fc14.x86_64 installed.  I haven't tried
> uninstalling and re-installing PackageKit yet.

Oops!  Please ignore comment 2, I commented on the wrong bug.  :-$
Comment 4 Bruce Alcorn 2010-10-18 07:16:24 EDT
I'm getting this problem in a fresh F13 install, but may have found a cause.

It seems that (for me, at least) the "Educational Software" meta-package is failing. No error message is given by the GUI, but if I run 

gpk-application -v

then select the Education package, and click "Apply", the CLI returns the following:

 - failed to install packages: could not do simulate: No packages were found in the education group for education-()meta.


If I select multiple packages, including the Education package, the described behaviour occurs.

Deselecting the Education package causes the software to behave as expected.
Comment 5 Bruce Alcorn 2010-10-19 11:43:49 EDT
Further research suggests this is probably a duplicate of Bug 589119.
Comment 6 Richard Hughes 2010-10-19 14:18:59 EDT

*** This bug has been marked as a duplicate of bug 589119 ***

Note You need to log in before you can comment on or make changes to this bug.