Bug 606294 - cannot login on serial console when specifying console=ttyS0,115200n8 console=tty0
cannot login on serial console when specifying console=ttyS0,115200n8 console...
Status: CLOSED DUPLICATE of bug 597370
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: upstart (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Petr Lautrbach
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 07:34 EDT by Stefan Assmann
Modified: 2010-06-21 07:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 07:42:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2010-06-21 07:34:38 EDT
Description of problem:
Not sure if upstart is really the problem, please reassign if necessary.

The problem is that the login prompt doesn't show on the serial console if another console=<something> is specified on the kernel command line.
Example:
With
kernel /vmlinuz-2.6.32-36.el6.x86_64 ro root=/dev/mapper/vg_intelsunriseridge01-lv_root rd_LVM_LV=vg_intelsunriseridge01/lv_root rd_LVM_LV=vg_intelsunriseridge01/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=auto console=tty0 console=ttyS0,115200n8
The serial console login prompt shows up:
[  OK  ] crond: [  OK  ]
[  OK  ] atd: [  OK  ]

Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)
Kernel 2.6.32-36.el6.x86_64 on an x86_64

intel-sunriseridge-01.lab.bos.redhat.com login:


With
kernel /vmlinuz-2.6.32-36.el6.x86_64 ro root=/dev/mapper/vg_intelsunriseridge01-lv_root rd_LVM_LV=vg_intelsunriseridge01/lv_root rd_LVM_LV=vg_intelsunriseridge01/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=auto console=ttyS0,115200n8 console=tty0
The serial console output stops at 
Starting crond:                                            [  OK  ]
Starting atd:                                              [  OK  ]


Version-Release number of selected component (if applicable):
kernel-2.6.32-36.el6.x86_64
upstart-0.6.5-5.el6.x86_64

How reproducible:
always
Comment 1 Petr Lautrbach 2010-06-21 07:42:53 EDT
Gettys are automatically spawned only for the primary console, see /etc/init/serial.conf

*** This bug has been marked as a duplicate of bug 597370 ***

Note You need to log in before you can comment on or make changes to this bug.