Bug 606308 - oprofile-jit: libjvmti_oprofile.so is not built
oprofile-jit: libjvmti_oprofile.so is not built
Status: CLOSED DUPLICATE of bug 463223
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: oprofile (Show other bugs)
6.0
All All
low Severity high
: rc
: ---
Assigned To: William Cohen
qe-baseos-tools
:
Depends On:
Blocks: 463393
  Show dependency treegraph
 
Reported: 2010-06-21 07:54 EDT by Hendrik Brueckner
Modified: 2011-05-13 08:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: oprofile-0.9.6-7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 08:57:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hendrik Brueckner 2010-06-21 07:54:41 EDT
Description of problem:

The libjvmti_oprofile.so is not built and packaged in the oprofile-jit package. Without the libjvmti_oprofile.so library, performance profiling is not available for Java programs.

The lib is not built because the in the %prep section of the rpm specfile, the openjdk-include.tar.gz tarball containing required header files are not extracted.  The oprofile configure script does not find the required jvmti.h file and, therefore, the lib is built and packaged.

Fix proposal: extract the the openjdk-include.tar.gz during the %prep step of the rpm build. For example, add the following into the %prep section (after the first %setup):
%setup -T -D -a 1


Version-Release number of selected component (if applicable):
oprofile-0.9.6-5.el6.src.rpm

How reproducible:
always

Steps to Reproduce:
check the file list of the oprofile-jit if "/usr/lib64/oprofile/libjvmti_oprofile.so" is included
  
Actual results:
The lib is not included.

Expected results:
"/usr/lib64/oprofile/libjvmti_oprofile.so" is included.

Additional info:
The problem has been found on s390x, but it might exist on other architectures.
Comment 2 RHEL Product and Program Management 2010-06-21 08:23:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 William Cohen 2010-06-21 08:57:39 EDT
This should be fixed in oprofile-0.9.6-7.el6.

*** This bug has been marked as a duplicate of bug 463223 ***
Comment 4 Georg Markgraf 2010-06-21 09:21:42 EDT
I guess that fix can be expected with snap7 - right?

Note You need to log in before you can comment on or make changes to this bug.