Bug 60631 - I cannot get core dumps
Summary: I cannot get core dumps
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-03 15:51 UTC by Kern Sibbald
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 22:28:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kern Sibbald 2002-03-03 15:51:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
Since upgrading from RH7.1 to 7.2, I nolonger get core dumps
for programs that terminate with abort(). The following program:
=== test.c ====
main ()
{
 abort();
}
===== 
compiles and links with:
  make test
It runs with:
   ./test 
and produces:
[kern@polymatou kern]$ ./test
Aborted

But there is no core dump. There is no
core.* either.

How do I get core dumps?

Thanks

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Input program given above
2.Make program
3.Run program
	

Actual Results:  "Aborted" prints.

No core dump produced.

Expected Results:  To see a core dump

Additional info: Here is a uname -a
Linux polymatou.sibbald.com 2.4.7-10 #1 Thu Sep 6 17:27:27 EDT 2001 i686 unknown

Glibc: glibc-2.2.4-19

Comment 1 Need Real Name 2002-03-06 22:19:14 UTC
Thiis problem is very limiting for developers, please could you raise the priority 
and provide a patch ASAP.


Comment 2 Arjan van de Ven 2002-03-06 22:28:17 UTC
Can you check the ulimit's for core dumps ?

ulimit -c

does that

ulimit -c unlimited 

disabled any size limit on coredumps


Comment 3 Kern Sibbald 2002-03-07 08:24:15 UTC
That fixes the problem, thanks!

$ ulimit -c
0
$ ./test
Aborted
(no core dump -KES)
$ ulimit -c unlimited
$ ./test
Aborted (core dumped)
(core dump exists -KES)

Now that I know the solution for this problem,
I have to admit it is probably a reasonable default
as it adds additional security by not having core
dumps of sensitive programs lying around.





Note You need to log in before you can comment on or make changes to this bug.