Bug 606402 - ORA error in plugin registration at server startup ORA-00604, ORA-00942
ORA error in plugin registration at server startup ORA-00604, ORA-00942
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Database (Show other bugs)
3.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 10:37 EDT by Jay Shaughnessy
Modified: 2014-05-29 16:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Oracle 10g (XE)
Last Closed: 2014-05-29 16:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2010-06-21 10:37:32 EDT
I've seen a couple of times the following error (see next comment) on server startup using Oracle 10g (XE).


10:03:32,152 ERROR [ProductPluginDeployer] Failed to register RHQ plugin file [file:/C:/workspace/rhq/dev-container/jbos
sas/server/default/deploy/rhq.ear/rhq-downloads/rhq-plugins/jopr-jboss-as-plugin-3.0.0-SNAPSHOT.jar]
java.sql.SQLException: ORA-00604: error occurred at recursive SQL level 1
ORA-00942: table or view does not exist

        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:439)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:395)
        at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:802)
        at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:436)
        at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:186)
        at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:521)
        at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:205)
        at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:1008)
        at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1307)
        at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3449)
        at oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:3530)
        at oracle.jdbc.driver.OraclePreparedStatementWrapper.executeUpdate(OraclePreparedStatementWrapper.java:1062)
        at org.jboss.resource.adapter.jdbc.CachedPreparedStatement.executeUpdate(CachedPreparedStatement.java:95)
        at org.jboss.resource.adapter.jdbc.WrappedPreparedStatement.executeUpdate(WrappedPreparedStatement.java:365)
        at org.rhq.enterprise.server.resource.metadata.ResourceMetadataManagerBean.streamPluginFileContentToDatabase(Res
ourceMetadataManagerBean.java:417)
        at org.rhq.enterprise.server.resource.metadata.ResourceMetadataManagerBean.registerPluginInNewTransaction(Resour
ceMetadataManagerBean.java:339)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at 

... 

org.jboss.ejb3.stateless.StatelessLocalProxy.invoke(StatelessLocalProxy.java:84)
        at $Proxy345.registerPluginInNewTransaction(Unknown Source)
        at org.rhq.enterprise.server.resource.metadata.ResourceMetadataManagerBean.registerPlugin(ResourceMetadataManage
rBean.java:297)

...

org.rhq.enterprise.server.core.plugin.ProductPluginDeployer.registerPluginJar(ProductPluginDeployer.java:504)

        at org.rhq.enterprise.server.core.plugin.ProductPluginDeployer.access$000(ProductPluginDeployer.java:56)
        at org.rhq.enterprise.server.core.plugin.ProductPluginDeployer$LatchedPluginDeploymentService.executeService(Pro
ductPluginDeployer.java:613)
        at org.rhq.enterprise.server.core.concurrency.LatchedServiceController$LatchedService.run(LatchedServiceControll
er.java:266)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
10:03:35,198 INFO  [PluginMetadataParser] There is no resource type named [JBossAS Server] from a plugin named [JBossAS]
. This is probably because that plugin is missing. Resource Type [JBossCacheSubsystem] will not have that missing type a
s a possible parent.
Comment 1 Jay Shaughnessy 2010-06-21 10:40:37 EDT
Some initial web research point to this being some sort of internal corruption that can typically be fixed with:

   drop snapshot log on table_a;

where table_a is the table that seems to be causing the problem. In this case, RHQ_PLUGIN.

Recreating the db completely certainly seems to fix the issue but may be a bit drastic.
Comment 2 Corey Welton 2010-09-24 09:16:02 EDT
Triaged 21-Sept
Comment 3 Jay Shaughnessy 2014-05-29 16:34:19 EDT
use the workaround

Note You need to log in before you can comment on or make changes to this bug.