Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606452 - $lt_unset is used but never set by libtool
$lt_unset is used but never set by libtool
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libtool (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 12:14 EDT by Kirby Zhou
Modified: 2013-03-07 07:40 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 07:40:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix. (1.43 KB, patch)
2013-01-09 09:43 EST, Pavel Raiskup
no flags Details | Diff

  None (edit)
Description Kirby Zhou 2010-06-21 12:14:18 EDT
Description of problem:

$lt_unset is used byt never set by libtool

Version-Release number of selected component (if applicable):

libtool-1.5.22-7.el5_4


How reproducible:

100%

Steps to Reproduce:

]# locale
LANG=en_US
LC_CTYPE=zh_CN.gbk
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE="en_US"
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
[root@xen-727057^10.227 gchar]# libtool --mode=execute gdb
  
Actual results:

/usr/bin/libtool: line 6823: LC_ALL: command not found
/usr/bin/libtool: line 6823: LC_COLLATE: command not found
/usr/bin/libtool: line 6823: LC_MESSAGES: command not found
GNU gdb (GDB) Red Hat Enterprise Linux (7.0.1-23.el5_5.1)


Expected results:

no error happens

Additional info:

]# fgrep -n unset /usr/bin/libtool
40:(unset CDPATH) >/dev/null 2>&1 && unset CDPATH
5226:       relink_command="{ test -z \"\${$var+set}\" || unset $var || { $var=; export $var; }; }; $relink_command"
5656:(unset CDPATH) >/dev/null 2>&1 && unset CDPATH
5972:     relink_command="{ test -z \"\${$var+set}\" || unset $var || { $var=; export $var; }; }; $relink_command"
6819:               $lt_unset $lt_var


it seems we should use 'unset' directly instead of lt_unset
Comment 1 Pavel Raiskup 2013-01-09 09:43:33 EST
Created attachment 675590 [details]
Proposed fix.

Fix for this should be easy.  I just extracted relevant part from up2date
libtool.

Pavel
Comment 2 Pavel Raiskup 2013-03-07 07:40:10 EST
I am sorry but as I see now - it is now too late in the RHEL-5 release cycle.
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production
phase 2 [1] release of RHEL-5.  Since phase 2 we'll be addressing only security
and critical issues.

This one issue is not present in RHEL-6 therefore I am closing the bug as
NEXTRELEASE.

Pavel

[1] https://access.redhat.com/support/policy/updates/errata/

Note You need to log in before you can comment on or make changes to this bug.